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U.S. Export Administration Act: Restrictions on Exporting
Software
The Software includes cryptographic software that may be subject to export controls
under the U.S. Export Administration Act. The Software may not be exported to any
country or to any foreign entity or “foreign person” to the extent prohibited under
applicable U.S. government regulations. By downloading or using the Software, you are
acknowledging and agreeing to the foregoing limitations on your right to export or reexport the Software, and are also representing and warranting that you are neither on
any of the U.S. government’s lists of export precluded parties nor otherwise ineligible to
receive software containing cryptography that is subject to export controls under the
U.S. Export Administration Act.
Administrators must be aware that allowing users outside the United States to access
data via certain DI-Clients qualifies as exporting encryption software (either the client
executable or the Java applet sent to the browser). Export or re-export of encrypted
software must be in accordance with the Export Administration Regulations. Diversion
of encryption software contrary to U.S. law is prohibited.

More Information
More information about trademarks, product warranty, and third-party license notices is
available in your DI software Help system. At the bottom of any Help page, click
Product Information, and then click Disclaimers, Trademarks, Warranty, and
Third-Party Licenses.

Course Description
This course teaches you how to:
l

Complete the extract, transform, load (ETL) process

l

Provide usable data structures to analysts and information consumers

l

Schedule and monitor routine updates to the data

l

Provision users and control their access to the data

Who should attend?
l

Developers who perform any part of the ETL process

l

Anyone who creates data structures for use by others

l

Administrators who are responsible for user provisioning and security

How long does the course last?
l

Onsite—Two days

l

Online—Six, two-hour sessions
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About Dimensional Insight

About Dimensional Insight
Dimensional Insight develops and deploys business intelligence solutions for
complex, highly-regulated, and compliance-driven industries.

Our Vision for Information Delivery
Dimensional Insight believes that you need the ability to access your data at any
time. Whether you are in the office, at home, or are traveling, you can view
current spreadsheets, documents, pictures, email, reports, and structured data—
all the data that helps you understand where your business stands.

Dimensional Insight

1

About Dimensional Insight

Workbench

Minimize Information Overload
As organizations grow, so do their databases—and these databases are often
built to serve single functions. When users share spreadsheets and text files and
use them to create reports, the results can be inconsistent.
How do you manage who can access the data? And how do you know whether
the data is up-to-date?
When the data is unclear, collaboration becomes a challenge.
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Single Shared Version of the Truth
Diver Platform provides tools to create a single, shared version of the truth. This
ensures that the information presented across the organization is consistent and
accurate.

Dimensional Insight
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One Source of the Truth Across the Enterprise
With Diver Platform, you can validate the data and make it available to users on
laptops, tablets, and mobile phones.
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Our Complete Solution
Diver Platform software tools support all of your data management needs by:
l

Extracting data from your enterprise systems

l

Validating the quality of that data

l

Applying business rules

l

Securing the data for controlled distribution

Diver Platform clients support your business intelligence needs by:
l

Constructing dashboards

l

Performing advanced analysis

l

Sharing reports on multiple devices

Dimensional Insight

5

About Dimensional Insight

Workbench

Diver Platform
Diver Platform is a centralized information delivery system, providing data
transformation, administration, and end-user presentation in a complete
package. This gives a single, shared version of the truth from distinct data
sources.
Information consumers work with dashboards that allow them to explore and
discover insights from the data. With these insights, they can collaborate
confidently with other users.
Business analysts can perform ad hoc and advanced analysis and create various
reports.
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Diver Platform Architecture
The Diver Platform architecture consists of acquiring source data, organizing it
into a uniform state, and then delivering the single, shared version of the truth to
all users.

Diver Platform allows you to acquire data from multiple sources:
l

l
l

Primary enterprise source systems, such as Meditech, SAP, and other lineof-business applications
Stored enterprise data, such as data warehouses, data marts, and data lakes
Auxiliary files, such as goals data controlled by managers outside the data
stream

The rules engines for extract, transform, and load (ETL) allow you to organize the
source data into different structures for data modeling:
l

A single place to define your data governance with business rules

l

A single place to construct and validate columnar data sets

l

A single place to define and apply security rules to protect your data

Diver Platform clients deliver your data for further analysis by way of:
l

Live dashboards on websites

l

Tools that support advanced analytics

l

Shared data sets that support a consistent version of the truth

Dimensional Insight
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A Central Platform for Different Users
Your organization needs more than simple analytic tools. You need a single
platform that supports your staff throughout the data life cycle, including
storage, analysis, and sharing.
Using Diver Platform means that all members of your staff—from data architects
to stakeholders—have the tools to do their jobs.

Diver Platform caters to specialized user needs:
l

l

l

8

Power Users analyze data. They focus on data discovery, look for trends,
outliers, and opportunities, and report their findings.
Information Consumers apply the data in their daily job functions. They
make informed decisions based on dashboards and reports and use mobile
access to both structured and unstructured data.
Developers develop the data with world-class ETL tools and manage data
access with master data management tools. They work with stakeholders
to validate the numbers and create robust and intuitive applications.
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Workbench

Workbench Overview

Workbench Overview
In this section, we will discuss:
What is Workbench?
Dimensional Insight Engines and Clients for Analytics
Workbench Interface
Workbench Components
Using Workbench Explorer
Status Bar
Workbench Help

What is Workbench?
Welcome to Workbench, the centerpiece of Dimensional Insight Diver Solution
7.0 and Diver Platform with Spectre or DiveTab.
Workbench is an integrated development environment (IDE), designed to
simplify and speed up development of applications that process and present
your data. Workbench uses a central project repository to manage and control
the back-end building blocks. With Workbench, you can test and visually
examine your data flows and processes. In addition, Workbench provides one
point of entry for all your Diver Solution 7.0 and Diver Platform data servers,
easing the task of developing, testing, and managing multiple data projects.
Workbench allows you to set schedules for the extract, transform, and load (ETL)
tasks associated with your projects. Scheduling project tasks ensures that your
transformed data is up to date and available to users when they need it.
In Workbench, you can organize and transform your raw data into useful data
sources that are then presented to the end-user applications as shown in the
following diagram. You can design how to present the data in diveable
dashboards and graphical and tabular displays. With the DiveTab, DivePort, and
ProDiver clients, users can further manipulate data as well as formulate and
answer questions relative to their roles in the organization.

Dimensional Insight
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Dimensional Insight Engines and Clients for Analytics
Are you new to Dimensional Insight and Diver software? If so, this overview
should help you get grounded.
There are two engines for building output from your data:
l

l

Model Builder Engine—Diver Solution 7.0 engine for building models.
No additional license is required to use the model engine.
Spectre Build Engine—Diver Platform 7.0 engine for building cBases. An
additional license is required to use the Spectre engine.

DI software executes in a client/server environment.
DiveLine is the server component that provides a flexible and scalable system
for the authentication of users and centralized access to data. The Spectre engine
is integrated with DiveLine and is used to build and query cBases as well as
perform real-time calculations while delivering data to the clients. The Builder
engine is used to build DI models which are also accessed by the clients.
Back-end clients are aimed at consultants, developers and IT personnel; front-end
clients are intended for analysts and other end users of business intelligence
data.
Back-End DI Clients
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Workbench An integrated development environment (IDE) centralizing
access to all Dimensional Insight development tools. Its projectbased approach allows for collaboration from a central
repository, as well as administration of multiple Dimensional
Insight applications.
The back-end components in Workbench are:
Server Settings (DiveLine)—Manage users, groups, and
properties; specify audit requirements; configure and control
access to data.
Spectre*—Define, build, and query the columnar data structure
known as a cBase.
DiveTab*—Design and build a configuration layer that presents
data as well as other kinds of media to users on an iPad.
Visual Integrator—Define steps for the extraction,
transformation and loading of raw data into cBases, classic
Models, and Measures.
Production—Configure repeatable process flows for the
automation of data preparation and delivery tasks in a
scheduled live environment.
DiveMaster—Organize the cBase and model data by
categorizing columns for easy access by the end users. For
classic Models, merge and consolidate data sets.
Visual Builder—Define and build the indexed data structure
known as a classic Model.
DIAL (Dimensional Insight Access Language)—Prepare and
schedule email delivery of reports for targeted users.
ProDiver

A desktop Windows client to view and analyze your data. You
use ProDiver for data validation and to develop and save
Markers and DiveBooks. See the separate ProDiver Help
delivered with the software.

DivePort

A zero-footprint client to construct a data portal on a Web
Application Server. You use Web portlet technology to create
and configure both pages and portlet instances to customize
presentation of data from multiple sources. See the separate
DivePort Administrator Help delivered with the software.

Dimensional Insight
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*Diver Platform only
Front-End DI Clients
Bridge

Web application based on DivePort technology that gives you
seamless access to existing and future DI applications under one
umbrella. This allows you to build new applications and portals
taking advantage of the latest Diver Platform functionality without
first upgrading existing applications.

DivePort

Zero footprint client that displays in a browser. You can navigate
through the portal and interact with data displayed on customized
pages.

DivePort
In

Zero-footprint browser client that includes input technology to

DiveTab
iPad App

Tablet based mobile technology that delivers self-service

allow you to enter and save data to your Diver project.

reporting and analysis to facilitate data-driven decision making. It
runs on an Apple iPad or iPhone.

DiveTabPC

Windows desktop version that replicates all functionality found in
the DiveTab app.

DIWindows client that can be configured to automatically send
Broadcast
email based on a defined set of business rules and parameters, as
applied to the current data. DI-Broadcast manages schedules and
events and executes DIAL scripts.
ProDiver

Windows desktop client to explore your data; perform ad hoc
dives; reformat presentations as reports or in one of over four
dozen graph options; save and reopen presentations after data is
refreshed.

NetDiver

Zero-footprint client that displays in a browser and replicates
ProDiver functionality.
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Workbench Interface
This topic describes the Workbench user interface components in a typical
working environment. The Workbench integrated development environment
(IDE) opens the different file types from the Explorer into tabs in the Main
Window Space. These tabs display content using either a visual editor or the
text editor, depending on the file type.
Context menus are available throughout the interface: Explorer, tabs and
properties panes within the Main Window Space, tab titles, and the Status Bar.
The sample screen shot presents a typical Workbench screen showing an open
Visual Integrator script with a Builder object selected, which provides a sample of
the object properties panes.

Main Window Space:
l

Tabs—A file opened from the Explorer or administrative tabs opened from
the Tools menu (Server Settings and Project Settings). Click the tab title

Dimensional Insight
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to activate a particular tab for editing/testing
l

l

l

Secondary Tabs "bread crumb trails" (only appear on some tabs)—
Navigate sub-tasks of the active Visual Integrator script by clicking the
triangle to expose choices (similar to navigating in Windows Explorer)
Task Flow Panel—Create and edit scripts with visual icons (Visual
Integrator, Production, Visual Builder, and limited DiveTab modules)
Object Properties Panes—Set properties and attributes for the currently
selected object (Builder in this example); each object has one or more
required attributes

Tool Windows:
l

l

Explorer—On the left, navigate folders and files within your project
(supports drag-and-drop operations to and from Windows Explorer)
Object Palette—On the right, select an object to place it into the currently
open script (supports drag-and-drop operations onto the Task Flow Panel)

NOTE: The Explorer tool window is always present, though you can unpin it and
have it collapsed, while the right-hand tool window (Visual Integrator Object
Palette in the example above) changes and may disappear altogether, depending
on the active tab type.
What displays in the Main Window Space depends on the active tab type. The
example above shows a Visual Integrator script tab. Other tab types may include
different GUI editors (based on the file type). Many file types also allow editing
with the text editor, which may be particularly helpful for debugging scripts.
Settings for the DiveLine server and projects also open in tabs.

Workbench Components
The Workbench client is an IDE with the following components.
Component Description
Spectre Build Used to create a configuration file that defines the
transformation of data into a cBase.
Visual

Used to create a description file that describes the

Builder

transformation of data into a model.

Visual

Used to create objects to manipulate input data to transform it

Integrator

and output to either model or cBase.
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Component Description
DiveMaster

Used to create DivePlans that specify to client software (for
example, ProDiver and DivePort) how the data should be
presented.

Production

Used to create workflows for building models or cBases and
schedule data manipulation tasks.

DiveTab

Used to create tablet-based applications for self-service
reporting and analysis.

Text Editors

Used to create and edits various scripts that do not have a GUI
(for example, cPlans, Dives, Measures, Measure Factory
configurations and plug-ins, DIAL, and QuickView sets.

Using Workbench Explorer
Workbench Explorer is similar to Windows Explorer. You can drag and drop files
in to and out of the Explorer tree and double-click files to open them in the
default editor. You can accomplish most tasks with the context menu commands.
The context menu commands available in Workbench Explorer change
depending on the selected item.
Explorer
Level

Available Context Commands

All

Copy, Cut, Paste, Delete, Rename, and Version Control

Project

Close Project and Project Settings
New, Refresh, Edit Access Control, and Find In Files

Folder

New, Refresh, Edit Access Control, and Find In Files

File

Open, and Open with (can choose the default)

Dimensional Insight
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Level
Scripts

Workbench

Available Context Commands
Run, Test, Run Script, Test Script, Open, and Open with (can choose
the default), and add task or tasklists (Visual Integrator only, when
the script is expanded)

Status Bar
The Status Bar at the bottom of Workbench is an informational tool window.

If any items exist in the Errors or Running sub-tab, a parenthetical number
appears to the right of the label.
The Status Bar tool window is collapsed by default. As with the other tool
windows, you can expand and pin the Status Bar open when necessary.
The following shows examples of the five status bar sub-tabs:
Errors
The Errors sub-tab displays any errors during the current Workbench session.
You can double-click a row and the file opens with focus at the error point.
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Running
The Running sub-tab displays a list of any running scripts. You can view the
progress as well as pause, resume, and cancel the task.

Finished jobs
The Finished jobs sub-tab displays all the scripts that ran during the current
Workbench session. You can double-click a row to open the Output sub-tab for
that script.

Output
The Output sub-tab displays the output for the most recent script. You can use
the drop-down list to view the output of any script that ran during the current
Workbench session.

Find Results

Dimensional Insight
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The Find Results sub-tab shows all of the search results from a search using the
Find in Files feature (Edit > Find In Files). You can double-click a result to open
the file containing the search term.

Workbench Help
You can access Workbench Help from the Workbench menu bar.

This Help system offers a search box that can help you find information. You can
narrow the search by selecting a filter from the list located between the Search
box and the search icon.
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IMPORTANT: The search function is based on keywords and does not support
most special characters.
If you enter a sentence or phrase in the search box, the Help applies an AND
operator to the major words in the phrase. For example, if you enter "How do I
add a column to a graph?" the Help system searches for pages that contain all
four major words: how, add, column, and graph (and returns 0 matches). In this
case, entering "add column" as search criteria produces better results. To search
for a particular phrase, enclose the phrase in quotation marks.
TIP: Clicking blue arrows and text in the Help system can reveal images or details
about the subject matter.

Dimensional Insight
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Workbench Connections
In this section, we will discuss:
Connections Overview
Working with Workbench Connections
Workshop

Connections Overview
The Diver Solution and Diver Platform are client/server systems. Workbench
projects are stored on the DiveLine server. The Workbench client needs to
connect to the DiveLine server to work with the project files.
Workbench connections to the DiveLine servers are created and managed with
Connection Manager (File > Open Connection).

Working with Workbench Connections
This topic describes how to create, edit, and delete Workbench connections.
Creating a New Connection
To create a new connection:
1. Click File > Open Connection.
The Connection Manager opens.
2. Click Add Connection (green plus sign) at the top of the left Connections
pane, and select the connection type:

o

DiveLine—Used for typical Dimensional Insight projects (except DiveTab
projects)

o

DiveTab—Used for DiveTab projects

3. Enter details for the connection in the right pane. See the following list for
the details.
4. Click Login.

Dimensional Insight
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DiveLine connections:
l

l

l

Server—Enter the server name or an IP address to connect to.
NOTE: What you type here is duplicated in the Connections list on the left
pane and becomes the connection name (unless you also add a label).
Port—Enter a port number for this connection (check with your system
administrator).
Label—Enter a label for this connection (optional).
NOTE: This label overrides the text entered into the Server field for the
connection name as it displays in the left Connections pane.

l
l

l

l
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User—Enter the user name for this connection.
Password—Optionally enter the password for this user and connection. If
no password is provided here, and authentication it is not Web Server, the
user will need to provide a password each time the connection is made.
Connect on startup—Select this to have the connection login on startup
(defaults to False). If credentials are missing when a login attempt is made,
an error message displays on the Start Page under the Default
connections area.
Use Credentials For WebAuth—Select to allow credentials to be used for
the DiveLine Web Authentication URL. Defaults to False and is only
applicable for servers using Web Server authentication.

Dimensional Insight
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Sample DiveLine connection

Opening and Closing Connections
This topic describes how to open and close DiveLine server connections.
Opening Connections
To open a previously defined connection:
1. Click File > Open Connection.
The Connection Manager opens.
2. Select the connection in the Connection Manager dialog box and click
Login.
If your credentials are stored in Connection Manager, the connection is
made.
If your credentials are not stored in Connection Manager, you are
prompted for them before the connection is made.
You can now open an existing project or create a new one.

Dimensional Insight
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Alternatively, you can use the Open Connection icon at the top right (next to
the Connections list), or the Recent Connections links on the Quick Start Bar
from the Start Page tab, to access one of your previously established
connections.
Closing Connections
To close an open connection, choose one of the following:
l
l

Click File > Close Connection.
Click the Close Connection icon at the top right (next to the Connections
drop-down list).

Getting DiveLine Server Information
You can get information about the DiveLine and Production Service versions.
To get information about the current connection:
1. Place the mouse over the connection icon to the left of the Connections
list.

The server information displays in a pop-up text box.
2. Right-click while the information is displayed to copy the information to
the clipboard.
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Projects
In this section, we will discuss:
What are Projects?
Creating a New Project
Default Folder Structure
Examining Your Data
Home Project Overview
Workshop

What are Projects?
Workbench (Diver Solution 7.0) introduces the concept of projects. Projects in
Workbench are a collection of related files within a single directory tree that are
associated with a Diver Solution or Diver Platform implementation. In
Workbench, a project is specifically defined and the software acts upon this
definition.
The following are the main Workbench project features:
l

Abstraction—what is the project for?

l

Simplified file organization

l

Easily transportable—all pieces encapsulated

l

Self-contained access control files

Project Files
When you define a new project, a recommended structure is presented to
organize the parts, but there is flexibility. You can choose to start with an empty
structure or use the default structure and delete or rename folders to suit the
needs of your project and reduce visual clutter.
A project directory typically has folders for:
l

Raw data or source files

l

Temporary data in the process of being manipulated

l

Finalized data files

l

Document libraries

l

Image libraries

l

Scripts, often organized by type such as build, divetab, or prd

The following is a typical project directory structure.

Dimensional Insight
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Security
Access control is part of the project. Projects have self-contained access control
rules that are organized by users, groups, or user properties. Access control
options allow you to specify rules for accessing files and directories, rules for
viewing data records in cBases, Models, DiveTab areas (buttons) and pages, as
well as whole-project access.

Project Paths
Files within a project are referred to by their project path. The project root is a
forward slash ("/"), and then all other files are stored under that. So if you have a
folder called cbases within your project, and a sales.cbase file within it, the path to
the file is:
/cbases/sales.cbase

Project paths make projects completely portable. A project can be stored in one
place on one machine and in a completely different place on another. All
references to project files within scripts are easily resolved regardless of the
project placement on the server. Because of this, and in order to keep scripts,
markers, and dives as clear as possible, the use of relative paths to reach parent
or sibling directories (../data/foo.txt) is discouraged.

Aliases
You can create aliases to bring in data from outside the project. The aliases can
be to folders in another project on the DiveLine or to a system drive. Alias
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functions are like a UNIX link.

Mailing Lists
You can create mailing lists that are used to send notifications for the success or
failure of whole Production scripts or specific nodes as they are processed.

Creating a New Project
Prerequisite: To create a new project on a server, you must be a DiveLine
administrator.
To create a new project:
1. Open the New Project dialog box by using one of the following methods:
l
l

l

Click File > New > New Project
In the File > Open Project dialog box, at the lower left, click Create
New Project
In the Tools > Server Settings > Projects sub-tab, at the top of the
project listing, click Add Project
The New Project dialog box displays.

2. In the Project Name box, enter a name for the project.
3. In the Project Root box, edit the path or folder name if you want to use a
root other than the default. The Project Root automatically populates
using the currently active DiveLine connection projects path and appends
that path with the project name.
4. Select the Initial Contents.
l

l

Select Default Folder Structure to automatically generate the
recommended project directory structure.
Select Empty to create an empty project structure. You can then
manually create your own project folder structure.

Dimensional Insight
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l

Select Copy Project to create a copy of an existing project on the
same DiveLine server.

5. In the Description box, enter an optional description for this project.
6. In release 7.0(41) and later, leave Enable automated version control
selected to default to automatic commits every 30 minutes and whenever
the project is closed. DI recommends using the automated version control
feature for most projects.
The following image is an example completed New Project dialog box.

7. Click OK.
A new project is created and opens in Workbench Explorer.
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Default Folder Structure
A default folder structure is generated when you create a new project.

This structure is created when you create a new project and leave the Default
Folder Structure selected in the Initial Contents box.
NOTE: This structure represents the DI best practice for a project structure.
However, the structure remains flexible. You can delete or add folders if required,
or opt out altogether and create your own folder structure. Common additions
are security to group property lists together, and publish to hold content to
be shared across projects or using the home directory feature.
The following table describes the purpose for each of the default folders.
Directory
cbases*

Dimensional Insight

Version
Control?
No

Purpose
Storage for cBases created by the project.
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Version
Control?

Purpose

config

Yes

Storage for static or manually maintainable
specialized files used as data, such as Measure
Factory configuration scripts.

cplans*

Yes

Storage for cPlans.

data

No

Storage for raw data—often an aliased folder
to another project or system folder.

diveplans*

Yes

Storage for DivePlans.

diver

Yes

Storage for ProDiver files, such as Markers and
DiveBooks. This directory is intended to be a
target of aliases from the Home Project.

Yes

Storage for DivePort files, such as markers.
They must be placed in this diver sub-folder
to ensure that users clicking on a Launch in
ProDiver link in DivePort are able to open
them correctly. Could include Dive files for
DivePort.

Yes

Top-level organizing folder. In previous
releases, this was the storage for the DiveTab
scripts.

documents

Yes

Storage for document files that are called from
the DiveTab application—often PDF and movie
files.

images

Yes

Storage for images used in the DiveTab
application.

diveport

divetab

presentations Yes

scripts
docs
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Storage for PDF files used in the DiveTab
application.

Yes

Storage for DiveTab scripts.

Yes

Storage for any documentation developed for
the project.
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Version
Control?

Purpose

logs

No

Storage for Production logs. This location is set
on the Project Overview tab under Tools >
Project Settings > Project Overview >
logs. If you change the logs location, you
should add that folder to the version control
ignore patterns.

models*

No

Storage for Models created by the project.

programs

Yes

Storage for various scripts used in the projects,
such as Spectre Build and Dive, Integrator,
Production, DIAL, and Tunnel scripts.

staging

No

Temporary storage for generated files that
need to wait for other actions before they are
ultimately moved to another folder. For
example, cBases are built here before being
moved to the cbases directory.

temp

No

Storage for temporary files created during
project processing.

*These file types (cbase, cplan, diveplan, and mdl) are indirectly accessed in
ProDiver through markers, but are not intended for direct access by an end user.

Populating Project Structure
To get started developing your project, you need to bring some data files and
perhaps some existing scripts into Workbench. Many additional files are created
in Workbench as you develop your project. Here are ways to bring files into the
Workbench Project structure:
l

l

l

Drag files from Windows Explorer directly into your project structure in
Workbench Explorer
Move files into Workbench project folders directly on the server, which
might include copying files or by using FTP
Set Aliases within the Project Settings in Workbench to where input data
is stored.
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Use the Copy Project feature from the Initial Contents list in the New
Project dialog box. For more information, see Creating a New Project in
the Workbench Help system.

Whichever method you use, you can see that the Workbench Explorer and
Windows Explorer windows automatically update and stay in sync.
For the long term scenario, as part of the development and test phases,
Production scripts will be created to refresh project data by performing ETL tasks
in a scheduled and controlled manner. This automation ensures that the latest
data is always available to end-users.

Examining Your Data
You can familiarize yourself with your data before you bring it into the
ETL process. Workbench has a table editor where you can view and study the
data files.
To view the data:
1. In Workbench Explorer, right-click the data file and click Open with
> Table Editor.
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2. Use the table editor to study the data.

NOTE:
l

Double-click the column separators to resize the columns to the heading
size

l

Scroll vertically and horizontally to examine all columns

l

Status bar shows information about the open file
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Home Project Overview
The home project is a special Workbench project used to organize user files. It is
designed to be the project that all users start in when they connect to a DiveLine
server from a client. When the home project feature is enabled, each user stores
all their files in their own home directory within the home project.
In addition, if you define project aliases in the home project, you can grant users
access to published content in other projects on the DiveLine server. If you use
project aliases in the home project, make sure that you define access control on
the target project, not the alias.
The home project automates new user access control settings, home directories,
default file access, and storage from client applications. This ensures that each
end user has access only to the content they should access. By consolidating all
users' file storage in the separate home project, you do not have to worry about
users accidentally changing other files within the data project.
Follow these overall steps to implement the home project feature:
1. Set the home project on the Projects tab. See Setting the Home Project
below.
2. Set the home directory and access pattern on the Users tab. See Setting the
Home Directory Settings on page 38.
3. Set aliases to the appropriate folders within other projects. See Setting
Aliases in the Home Project on page 40.
4. Create new users, leaving the DiveLine settings for Home Directory,
DiveBook, and App Template to use the defaults, which are now set by
the home project.
5. If required, retrofit existing users to use the home project defaults. See
Retrofitting Users for the Home Project on page 42.

Setting the Home Project
To set a home project for a DiveLine server:
1. With the DiveLine connection open, create a project dedicated as the
DiveLine home project. See Creating a New Project on page 29.
2. Click Tools > Server Settings > Projects, and expand the Settings
chevron at the top.
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3. Select the Assign Home Project check box to enable the home project
feature. Then, from the home-project list, select the project that you
created in step one for the home project.

NOTE: A warning icon might appear next to the selected home project with
an informational message. This operation allows all users access to the
home project with read access to the top-level directory. This sets the
Allow Access for all Users check box for the home project.
4. Save the tab.
The home project is set for this DiveLine server.
NOTE: When you open the home project, it has a different Workbench
Explorer icon to identify it as the home project. This same icon appears in
the Open Project dialog box, and a similar distinguishing icon appears in
the project listing (Server Settings > Projects).
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Setting the Home Directory Settings
Home directory settings are used when the DiveLine server uses the home
project feature, which is a special Workbench project to organize user files. The
Home Directory Format is a pattern that specifies the location of user home
directories relative to the root of the home project, and the Home Directory
Access specifies read and write access for each user's directory.
To configure home directory settings:
1. At the top of the Users tab, click the Settings chevron.
2. Select or type a Home Directory Format pattern as described in Home
Directory Format on the facing page.
3. Select a Home Directory Access as described in Home Directory Access
on page 40.
4. Save the tab.
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An example of the Users tab home directory settings is shown here.

Home Directory Format
The Home Directory Format sets the pattern for how home directories are
created in the home project. You use variables to set folder names.
The available choices are:
l

/Users/$(USER)

l

/Users/$(1)/$(USER)

l

/Users/$(1)/$(2)/$(USER)

/Users here creates the /Users folder at the root of the home project.

The $(USER) variable inserts the user's username. Usernames are caseinsensitive.
The $(#) variable, where # is a number between 1 and 9, selects the letter at that
position in the username as the folder letter.
NOTE: \ ? * : | " < > are invalid characters for the path name.
The following examples show sample formats and the resultant home directories
for a user with a username of smithjohn:
l

/Users/$(USER) creates:
/Users/smithjohn

l

/Users/$(1)/$(USER) creates:
/Users/s/smithjohn

l

/Users/$(1)/$(2)/$(USER) creates:
/Users/s/m/smithjohn

l

/Users/$(1)$(2)$(3)/$(USER) creates:
/Users/smi/smithjohn
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The last example selects the first three letters in the username to name a
containing folder. After the user smithjohn logs into the DiveLine server with a
Diver client such as ProDiver or NetDiver, the folder structure is created as
shown in the example here.

Home Directory Access
Select one of the following access patterns:
l

Grant owner read/write. Grant others read-only.

l

Grant owner read/write. Deny others.

The access control rules for each user's home directory are set as described.

Setting Aliases in the Home Project
The aim of the home project is to simplify the end-user experience and minimize
their access to content that they should not access directly.
Published content in the form of markers, DivePlans, and DiveBooks from other
projects on the DiveLine server are aliased into the home project. These files are
normally stored in a client-files directory or, after 7.0(31), in the diver
directory. These end-user files point to the content of the cbases and models
directories, but the users do not have direct access to the directories. This avoids
confusion for the end users and provides protection to the data.
For more information about the directories in a project, see Default Folder
Structure on page 31.
NOTE: Using aliases is not true security on the cbases and models directories
because the users must have read access to these directories. Using aliases to the
client-files or diver directories gives the users indirect access to the cBases
or models that these end-user files reference. A curious user can find their way to
see the directories in ProDiver, but it does take effort.
To set aliases in the home project:
1. Open the home project.
2. Click Tools > Project Settings.

40

Dimensional Insight

Workbench

Projects

The Project Settings tab opens.
3. Click Aliases, and create aliases to the published content folders from each
project that you want users to interact with. Normally these are the
client-files or diver directories in the projects. Name these aliases so
that the end users understand what content to expect.
4. Save the tab.
The aliases are created and now appear as blue folders in the home project
in Workbench Explorer as shown in the example here.

In ProDiver, the end users are pointed to their home directory, but if they
choose to navigate to the home project root in the Open or Save dialog
boxes, they only see the aliases and the Users folder as shown here.
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Retrofitting Users for the Home Project
If you implement the home project feature on a DiveLine server with existing
users, you need to retrofit these users to use the home project defaults for the
home directory and access pattern. This procedure does not change any access
settings already in place for existing directories.
To retrofit existing users for the home project feature:
1. On the Users tab, double-click an existing user.
The user opens for editing.
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2. On the General tab in the Home Directory box of the DiveLine section,
enter the path to the home directory. Ensure this matches the pattern from
the Home Directory Format field at the top of the Users tab as shown
here. You can copy and paste this setting from the Home Directory
Format field in the Settings chevron area of the Users tab.

3. Save the tab.
4. Have the user log into the DiveLine server with ProDiver. This creates the
user's folder within the home project.
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5. Place a DiveBook and App Template file in the user's home directory (if
used).
6. Return to the user's General tab, and set the DiveBook and App
Template in the DiveLine section. Leave the project as <HOME PROJECT>
and browse to select each from the user's home directory.
7. Save the tab.
For example:

The user is now set to use the home directory in the home project.
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cBases
In this section, we will discuss:
What is Spectre?
What is a cBase?
What is a Spectre Build?
Creating cBases with Spectre Build Scripts
Workshop

What is Spectre?
In the Diver Platform, Spectre is the data analysis software. Spectre is constructed
to take advantage of the latest hardware advances, such as parallel processing,
larger amounts of memory, and advanced compiler technology.
Spectre processes data from one or more databases and files to build a columnoriented database (cBase) that caches efficiently on both the server and client
device. This read-only columnar database is designed for efficient aggregation,
while easily ignoring columns that are not needed. This flexibility reduces the
need to make up-front decisions about data organization. Features in Spectre
Build can assist with data assessment and validation.
Spectre is used not only to build cBases—it also powers the DiveLine server
software for efficient queries from DI clients against those cBases. Spectre
includes a calculation engine that compiles formulas into machine code to
maximize hardware utilization. The result is efficient real-time calculations for
time series, dimension counts, and multitabs.
Spectre can be used as a database platform: the place to not only load the data,
but to perform ETL work. Think of a cBase as a table within the database.
Anything you can do with a database table you can do with a cBase. Building and
diving are very similar operations using Spectre. You can treat Spectre as a work
environment that you access and manipulate with Workbench.

What is a cBase?
A cBase is a proprietary columnar database optimized for aggregating
(summarizing) large volumes of data. It contains the raw data in binary format.
Everything is stored in columns, and each column has a type. A cBase is intended
to be kept mostly or entirely in memory and shared among all processors on a
server. The maximum number of rows a single cBase may contain is 232-1, which
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is 4,294,967,295. For best performance, DI recommends that cBases be located
on local SSDs (solid-state storage devices that use integrated circuit assemblies
as memory to store data persistently).
A cBase file supports date and period types with calendar support. It contains
metadata for:
l

Spectre Build scripts and logs

l

Column types and statistics

l

Data integrity errors and warnings

What is a Spectre Build?
A Spectre Build script is a configuration file that defines a data source from which
to create a cBase. Spectre can create a Build script from the data itself. The Build
script indicates the location of the input data, how to process it, and where to
write it out.
Opening this script with the Spectre Build editor shows the defaults and
assumptions that are made about the data.

Creating cBases with Spectre Build Scripts
There are two methods to generate a Spectre Build script from a text data file:
l

l

Right-click the data file and click Generate Spectre Build Script—This
method automates the required input and output elements based on the
data file name, and Spectre makes best guesses for the column type.
Click File > New > Spectre Build File—This method requires that you
provide the input and output elements. You also need to manually define
the type field for each column.

This procedure uses the first method (recommended as a first step) to take
advantage of the automation.
To create a Spectre Build script:
1. Right-click the data file in the Workbench Explorer and choose Generate
Spectre Build Script.
The Save File dialog box opens.

48

Dimensional Insight

Workbench

cBases

2. In the Save File dialog box, choose a location to store the new build file
(defaults to /programs recommended), make changes to the default file
name if desired, and click Save.
The Build script opens in a new tab.

NOTE:
o

Input file and path is automatically populated based on the data file

o

Output file name and location is automatically populated and takes the
form of /cbases/<data_file_name>.cbase

o

Column names are listed along with a data preview from the first row.
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o

All columns are set to keep

o

The Spectre engine makes a best guess at the type for each column
(except for datetime)

3. Make any adjustments if necessary, including:
o

Correcting input file properties such as encoding and delimiter (tab,
space, comma, semicolon, pipe)

o

Correcting the data types

o

Adding column aliases

o

Updating column properties

o

Adding comments for documentation

o

Adding any additional calculated columns

4. Save the tab.
5. Choose Run > Run Script or click the Run button (green circle with white
arrow) from the toolbar.
The script runs and places a cBase in the indicated location. If there are any
issues, inspect the Output tab at the bottom.
NOTE: If there are unsaved changes in the script, the Script has unsaved
changes dialog box opens with choices on how to proceed.
6. If needed, navigate to and open the cBase in ProDiver (right-click > Open
with > Diver) to see the results.
You can now iterate by making changes to your build script to fine tune the
columns, add calculated columns (if necessary), and re-run until you
achieve the desired results in ProDiver.
NOTE:
l
l

l

l
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Calculated columns use the same expression syntax as calcs in a cPlan.
There are additional attributes you can only apply when editing the script
in a text editor tab.
You can set a Workbench preference that has ProDiver open any cBase
successfully created with a Spectre Build script.
A new build script also has ODBC as an option for the input type. When
using a database table, Spectre uses the database metadata to help set data
types. A preview is not available when using ODBC input.
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cPlans
In this section, we will discuss:
What is a cPlan?
Creating a cPlan
Using a cPlan to Create Averages
Using a cPlan to Create a Time Series
Workshop

What is a cPlan?
A cPlan creates a view of the data. A cPlan script is used to merge, filter, and add
calculated columns to cBase data.
A cPlan defines a set of data sources and columns that will be available for use in
a dive within a Diver Platform client. Because you cannot save a cPlan in a Diver
client, a best practice is to design a cPlan layer when you design the cBase. Even
if not required, a cPlan gives flexibility later on since it is easier to modify than
the actual cBase. For example, calculations can be added to a cPlan long after the
cBase has been built.
This specialized view allows you to:
l

l

l

Present one or more inputs as a single data set. These inputs can be cBases,
cPlans, text files or ODBC tables.
Perform operations on the inputs such as filtering the data or adding data
via lookups.
Define and name new calculations such as summaries and time series
columns.

l

Inherit from another cPlan to make additional sets of columns available.

l

Add columns by importing calculations from a file.

l

Adjust the view of the cBase independent of the build process in order to
simplify access for users.

Creating a cPlan
To create a cPlan:
1. Choose File > New > cPlan.
2. In the New cPlan dialog box, choose a location to store the file (/cplans
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recommended), change the file name, and click Finish.
The cPlan opens in a Text Editor tab with default cPlan text.

3. Change the cbase-input value to a cBase.
TIP: Other options are cplan-input, dive-input, odbc-input, or
text-input.
4. You can now add calcs and time-series functions to configure the cPlan to
show more focused results in ProDiver.
5. Open the cPlan in ProDiver (right-click the cPlan and choose Open with >
Diver).
Notice that the columns shown in ProDiver are the columns from the cBase. Any
additional columns created with time-series in your cPlan are available in
ProDiver through Edit > Select Columns.
You can now work with this cPlan and create a DivePlan on top of it to create
ProDiver console categories.

Using cPlan Info
The output of a cPlan file can be viewed within Workbench to ensure you are
getting the expected results.
To view the output of a cPlan in Workbench:
1. In Workbench Explorer, right-click the cPlan and choose Run > Show
cPlan Info.
2. Inspect the output in the Output Status Bar.
Here you can see the results of columns created by the cPlan and return to the
cPlan to make changes as needed.

Using a cPlan to Create Averages
Creating averages is one example of using a cPlan to perform an additional
calculation on a compiled data set ( cBase).
An average is simply a denominator of the total divided by the number of rows
(count).
Spectre also has functions for generating maximum and minimum columns.
For example:
cplan {
cbase-input "/cbases/produce.cbase"
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calc "Average Sales" `average(value("Sales"))` format="#,##.00"
calc "Max Sales" `max(value("Sales"))`
calc "Min Sales" `min(value("Sales"))`
calc "Number of Customers" `dimcount(value("Customer"))`
calc "Ucount customer" `ucount(value("Customer"))`
}

When you open the cPlan in ProDiver, you need to use the Select Columns
dialog box to add any of these cPlan calculated columns. Click Edit > Select
Columns in ProDiver (see the ProDiver Help system that is included with
ProDiver).

Using a cPlan to Create a Time Series
Creating time series columns is another example of using a cPlan to perform an
additional calculation on a compiled data set ( cBase).
There are several items you can show using a Spectre time series calculation:
l

Show year-to-date

l

Show previous-year

l

Show difference

l

Show percent-differnce

For example:
cplan {
cbase-input "/cbases/produce.cbase"
time-series {
date "Ship Date"
anchor `top(max(value("Ship Date")))`
summary "Sales"
ranges {
year-to-date
}
variations {
previous-year {
difference
percent-difference
}
}
}
}

When you open the cPlan in ProDiver, you need to use the Select Columns
dialog box to add any of these cPlan calculated columns. Click Edit > Select
Columns in ProDiver (see the ProDiver Help system that is included with
ProDiver).
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DivePlans
In this section, we will discuss:
What is a DivePlan?
Creating a DivePlan
Creating Categories in a DivePlan
Workshop

What is a DivePlan?
A DivePlan creates additional organizational structure for how cBase or cPlan
data appears to end users. Data sets can have many dimensions and it can be
difficult for end users to find the information they need. A DivePlan lets you
organize these dimensions into meaningful categories to improve how they
display in the ProDiver console.

Creating a DivePlan
After you create a cBase, you can create a DivePlan to organize the data
presentation.
To create a DivePlan:
1. Click File > New > DivePlan.
The New DivePlan dialog box opens.
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2. Navigate to the diveplans folder, enter a file name, and click Finish.
You can alternatively right-click the diveplans folder and choose New >
DivePlan and then rename the file.
The DivePlan editor opens the new DivePlan with focus on the
Consolidate tab.
3. Click the Single Input tab. The Consolidate tab is only used when
working with models.
4. Drag and drop the cBase from Workbench Explorer to the
Model/Tunnel/cBase/cPlan box.
You can alternatively use the browse button in the
Model/Tunnel/cBase/cPlan box.
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The cBase loads, and all the columns and summaries are displayed in the
Elements panel.

You can now edit the DivePlan to shape what appears in the ProDiver
console.

Creating Categories in a DivePlan
The purpose of a DivePlan, with cBase or cPlan input, is to create meaningful
categories that group dimensions to control how ProDiver presents data in the
console. End users open the DivePlan, instead of the cBase or cPlan, so that they
can interact with the additional organization. You may find it useful to create
several DivePlans that filter the same data for various end-user needs.
To create DivePlan categories:
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1. Open a DivePlan that uses a cBase or cPlan for input.

Note the following defaults:
o

User model name—This is the name that appears in the ProDiver
console for the cBase or cPlan input. It defaults to the file name. You can
change this to a more meaningful name.

o

_hidden—Category where you can move dimensions that users do not
dive on. This category does not appear in the ProDiver console.

o

Other Dimensions—Category where uncategorized dimensions appear.
Before you create your categories, all the dimensions in the cBase appear
here. Click the plus sign (+) to expand and examine.

2. Examine the list of dimensions in the Column table or Other Dimensions
category and determine what categories you want to add.

60

Dimensional Insight

Workbench

DivePlans

For example, Time, Customers, Company, Product, and Invoice for a sales
data cBase.
3. Create each category with right-click on Categories > Add category and
enter the name.
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4. Repeat until you have all the categories.

5. Drag and drop dimensions to the appropriate category from either the
Other Columns or Column lists. You can use the typical Windows
conventions, such as selecting multiple items to move together.
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Example finished categories:
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DivePlan open in the ProDiver console:
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Additional Data Transformation
In this section, we will discuss:
What is Visual Integrator?
VI ETL Overview
VI Input Objects Overview
VI Process Objects Overview
VI Output Objects Overview
Creating cBases with Visual Integrator Scripts
Workshop

What is Visual Integrator?
Visual Integrator (VI) is a graphical user interface application for creating scripts
written in the Dimensional Insight Object Language. It provides the same
functions as the command line Integrator1, which it executes under the covers.
Visual Integrator allows you to manipulate Integrator objects without the need to
hand edit scripts.
Here is an example script with a Filein object selected (annotations follow).

1 The Diver Solution extract, transform, and load scripting tool. In version 7.0, Visual Integrator/Integrator is an integral part of Workbench.
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1. Task Flow panel—Place and arrange objects from the object palette into a
flow to input, transform, and output data.
NOTE: Objects on the task flow have a red bar across the top when a
required attribute is missing. You can hover the mouse over the object for
a pop-up warning that describes what is missing. The example here shows
that the object is missing the required attribute filenames and a note or
comment, which is a VI preference you can turn on or off.

2. Object Properties Pane—Set properties and attributes for the currently
selected object.
NOTE: This area defaults to the object properties when an object is selected
on the task flow, but changes depending on which tab below the area is
selected (3).
3. Additional Tabs—Select a link to change what displays in the object
properties area (bottom portion of the screen) to view or interact with. The
options are:
l Currently selected object or task panes—Filein-2-FIN (filein) in
this example
l

Parameters—Set user-defined parameters for this script

l

Results—Display the results of running the script

l

l

l

Logs—Display the log for the most recent run (logs for the current
Workbench session are found in the Output link on the status bar)
Columns—Display a grid showing the origin of each column for
each task
Input/Output Files—Display a grid showing the input and output
files used in the script
NOTE: If you set any of these sub-tab panes to auto-hide, you can
click any of the sub-tabs (links at the bottom of the script) to bring
the pane back and then reset the pin (top right) to bring the
properties back in place.

4. Object Palette—Choose Input, Process, and Output objects to place on
the Task Flow panel.
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NOTE: By default, ProDiver will launch and open when an Integrator script ends
with a Model or cBase output. You can change this behavior and set other Visual
Integrator preferences in the Workbench Preferences dialog box (Tools
> Preferences > Visual Integrator).

VI ETL Overview
Visual Integrator (VI) is used for ETL on the data. This process consists of using
the three VI object types to extract, transform, and load your data.
l
l

l

VI Input Objects—Input objects bring data into your data flow.
VI Process Objects—Process objects manipulate your data by performing
various operations such as calculations.
VI Output Objects—Output objects send your data flow out to either
end-user applications or as input into other data flow operations.
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VI Input Objects Overview
You use the Visual Integrator (VI) input objects to bring data into the workflow.
The table below describes each input object.
Visual Integrator Input Objects
Icon

Input
Object

Description

cBase

Accesses data in a DI cBase.

Datagen

Provides data generation capability.

Dict

Describes the format of an input or output file.

Directory Processes file system directories as input data.

Filein

FTP

List
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Accepts input from a set of external text files.

Accesses data from a remote system using the
Internet standard File Transfer Protocol (FTP).

Provides a method of defining an input table.
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Input
Object

Model

SQL

XML

Description

Accesses data in a DI Model.

Defines data to be accessed from an ODBC-accessible
database.

Extracts tabular data from XML documents.

VI Filein Input Object
The Visual Integrator (VI) Filein input object brings raw data into the script.
It accepts input from one or more text files. These text files are described by
column headers within the file or by an external dictionary file.
Object Attributes
You set attributes for the Filein object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The Filein column grid displays the columns from the input files.
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VI SQL Input Object
The Visual Integrator (VI) SQL input object brings database data into the script.
The object defines a data input flow from an ODBC data source in Windows,
unixODBC in UNIX, and DB2 in OS/400.
Object Attributes
You set attributes for the SQL input object in the attributes pane.

NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The SQL input column grid displays the columns from the input files.
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VI cBase Input Object
The Visual Integrator (VI) cBase input object allows you to bring cBase data into
the script.
The cBase input object accesses column data in a standard cBase or returns the
metadata about the cBase. It can retrieve the row-level data that was used to
build the cBase directly from the cBase or through a cPlan. It can also calculate a
Spectre dive and return the results. The object returns data for all columns in the
cBase. The order of the records is based on how they are stored in the cBase,
which is how they were input into the build.
NOTE: After the cBase data is pulled into a VI data flow, it becomes untyped data
again. The one exception is that date and period columns maintain the format
from the cBase.
Object Attributes
You set attributes for the cBase input object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The cBase input object column grid displays the columns from the input files.
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VI Process Objects Overview
You use the Visual Integrator (VI) process objects to manipulate and transform
data in the workflow. The table below describes each process object.
Visual Integrator Process Objects
Icon

Process
Object

Alias

Renames columns.

Break

Identifies break levels in the input flow.

Calc

Performs various calculations on data.

Concat

Concatenates multiple input flows.

Execute

Runs system commands.

Expand

Expands a single row into multiple rows.

Filter
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Description

Filters rows in a data flow that match specified
criteria.
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Process
Object

Join

Lookup

Description

Performs SQL-style joins.

Combines two input flows to form a single output
flow.
Generates additional records from a subset of

Multiply

records resulting in all possible binary
combinations of the input rows.

Qual

Rank

Rotate

Qualifies a data flow based on specified conditions.

Defines new calculated columns based on the entire
set of input rows.

Rotates information from multiple columns into
multiple rows.
Sorts the data flow based on a set of columns, and

Sort

changes the order in which the data appears in
subsequent objects later in the data flow.

SQL

Dimensional Insight

Allows SQL statements to be run against an ODBCaccessible database.
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Icon

Process
Object

Workbench

Description
Combines rows that are identical for a set of

Squash

dimension columns, and optionally summarizes
number columns.

Timeseries

Simplifies the creation of time period columns
based on a set of rows.

Trace

Helps to debug scripts.

Unrotate

Converts a single column into multiple columns.

VI Calc Process Object
The Visual Integrator (VI) Calc process object defines new columns or updates
existing columns with the results of calculations and passes the results into the
data flow.
A calculation string provides the formula for the column. This formula is defined
using Integrator calculation syntax. You can have multiple calculations in one
Calc object.
These calculation strings can refer to each other in the same Calc object.
However, references to a calculated column by another calculation use the
original value, not the new one when the referenced calculation has the Update
attribute set to True. Use a separate Calc object for access to both the original
and updated values.
Object Attributes
You set attributes for the Calc object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Defined Calculations
The defined calculations allow you to create new data columns in the data flow.

The general form of these calculations is: function(arg, arg, ...), where
the arguments can be column names, variables (parameters), or constants.
There are two methods for completing calculation definitions: type the string
directly into the definition panel, or pick functions and columns from the column
grid and functions panel.
Building a calculation definition by typing the string directly into the
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definition panel
1. Click in a row in the Name column, and specify a name for the calculation.
2. Click the Definition panel.
3. Enter the calculation expression in the form of: function(arg, arg,
...).
4. For each calculation definition, set the Initial Value, Persist and Update
flags as required.
NOTE:
l

l
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You can use the Ctrl+Space shortcut as you type in the definition to get a
pop-up pick list of functions to choose from. Enter the first few characters
of the function, select the desired function with the arrow keys or mouse
pointer, and then press Enter or double-click the function.

Color coding in the Definition pane visually displays the command syntax
elements: blue for function names, black for operators, and green for
column names.
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As you enter elements in the Definition pane, tooltips appear that give a
brief description of syntax. You can turn these tooltips off in the VI
preferences. For more information, see Visual Integrator Preferences.

Building a calculation definition using the column grid and calc
functions panels
1. Click in a row in the Name column, and specify a name for the calculation.
2. Double-click a function from the Functions pane. For example; concat(,).
That function is added to the calculation definition in the Definition pane.

3. With the focus still in place within the concat(,) function, double-click an
input column from the Input Column column in the column grid. For
example, Customer Name.
That column is added to the Definition pane.

4. Enter an open bracket in quotes followed by a comma ("[",).
5. Double-click the next column you want to concatenate. For example,
Customer ID.
6. Enter a comma and closed bracket in quotes (, "]") to complete the
calculation.
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The second column is added to the Definition pane.

NOTE: The Value column for this calculation updates automatically with
each change made in the definition pane.

Column Grid
The Calc column grid displays the input data flow.

Calc Functions
You can choose functions to insert in the calculation definition from the Calc
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Functions pane.

The functions are listed in logical, string, and miscellaneous categories by default.
NOTE: To list functions alphabetically without the categories, you can change a
preference. See Visual Integrator Preferences in WorkbenchHelp, and set the Sort
calc functions by category preference to False.
Double-click the function to enter it into the Definition pane.

Integrator Date Format
In Diver Platform, input columns that contain dates are processed differently
depending on which engine is processing the column.
l

l

Spectre is a typed language and all you need to do is indicate that the
input column is a date and Spectre can work with it—reinterpreting from
any input format to its preferred format.
Integrator is a non-typed language, so all date input columns are assumed
to be in the Integrator date format: YYYY/MM/DD.
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Integrator calculations only accept dates in this format or the ISO date
format (YYYY-MM-DD), where Y represents year, M represents month, and
D represents day.
If a column contains a date in another format and will be used in a
calculation, you must reformat it using the format_date() function.
Example:
format_date(Ship Date, "MM-DD-YY")

This translates the Ship Date column's format from MM-DD-YY to the Integrator
standard format (YYYY/MM/DD).

VI Filter Process Object
The Visual Integrator (VI) Filter process object filters the input data that gets
passed to the VI data flow. You can either keep or discard the items that match
the specified criteria according to the Action attribute.
Object Attributes
You set attributes for the Filter process object in the attributes pane.

NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The Filter column grid displays the input columns from the input data flow where
you can set the filter criteria.
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VI Lookup Process Object
The Visual Integrator (VI) Lookup process object combines two input flows with
a simple relational join to form a single output flow.
Two inputs are required: a primary input for the input flow and a secondary input
for the lookup flow. Either a single column or multiple columns from each flow
are used to match rows between the inputs. For each row in the input flow, the
value of the match columns are used to find a row in the lookup flow.
l
l

l
l

Both flows should be sorted appropriately.
If the lookup row is found, a set of columns are added to the input row as
part of the output flow.
If no row is found, empty strings are inserted for those columns.
If multiple rows matching the join keys are found in the lookup input, only
one of the rows is kept. A warning is issued, but the process continues
using the first value encountered.

NOTE: Lookup inputs are fully loaded into memory. If you have large lookup
input files, consider breaking them into smaller files. If you need to use these
large lookup files, consider using a Join process object instead.
You can perform a ranged lookup, where rows are joined based on a range of
values. This is useful when there are multiple values that map to a single value.
Ranged lookups let you create small lookup files instead of large files. That is,
instead of creating a row for each possible value and repeating the lookup value,
you can create one row with a range of values for each lookup value. When
editing, you only need to update one row rather than a series of rows.
Object Attributes
You set attributes for the Lookup process object in the attributes pane.

NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
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The Lookup column grid displays the primary input on the left, the secondary
input on the right, and the input columns and the join columns that you specify
in the middle.

The Lookup column grid has three parts:
l

l

l

Primary Input Grid (left)—Lists the columns defined in the primary input
object where you can select the columns to join. The Source Object
column displays the object name where the columns entered the flow.
Double-click the Source Object to change the task flow focus to that
source object.
Join Grid (middle)—Displays the columns that you have designated for
the join. See the following section about joining columns.
Secondary Input Grid (right)—Lists the columns defined in the secondary
input object where you can select the columns to join with. The Source
Object column displays the object name where the columns entered the
flow. Double-click the Source Object to change the task flow focus to that
source object.

Joining columns
To set the columns for the join:
1. From the Primary Input grid on the left, select the column, and click the
arrow between the left and middle grids.
The column is added to the Left Column column of the middle grid.

2. From the Secondary Input grid on the right, select the column you want
to join, and click the arrow between the right and middle grids.
The column is added to the Join With column in the middle grid.
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3. Repeat steps 1 and 2 for any additional joins.
4. Edit the Join Order column if necessary.
NOTE: Edit the Range End if working with a range lookup.

VI Rotate Process Object
The Visual Integrator (VI) Rotate process object rotates multiple input data
columns into multiple rows in the output flow.
The Rotate object uses two new columns:
l

l

Horizontal column—Holds a string that identifies the column that the row
represents.
Value columns—Holds the corresponding input value for the column.
There can be one or more value columns.

These new generated value columns become available as summary output
columns in the data flow.
The Rotate object creates multiple output rows—one for each column—for each
input row. For example, three columns with three rows of data become nine rows
of data in the output flow. The rotated columns do not appear in the output flow.
Object Attributes
You set attributes for the Rotate process object in the attributes pane.

NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The Rotate column grid sets the new horizontal column and one or more
summary value columns to rotate in the top section. Alternatively, you can define
a range to rotate in the bottom section.
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Examples
You can either rotate data by defining horizontal columns and values or by
defining a range.
Rotating Data by Defining Horizontal Columns and Values
With the following input data:

1. Set the Rotate object's New_Horiz_Column name attribute. For example,
Month. Note that this name populates the header for the new_horiz_
column in the top section of the column grid.
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2. In the top section of the column grid, replace the new value column header
with a name for the values column. For example, Revenue.

3. Enter values for the new_horiz_column column. For the month example,
2017-01 through 2017-12. A new row is added to the table after you enter
each value.
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4. Click in each cell for the new value column (that is Names for new
columns) and use the drop-down arrow to choose the appropriate item to
associate with the row. For example, Rev01 with 2017-01.
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Repeat for each row.
5. If rotating additional columns, click Add Column, supply a header, and
choose values.
6. Save the tab.
7. Right-click the Rotate object, and click Test Object.
In the results you see the rotated data.

Rotating Data by Defining a Range
With the following input data:

1. Set the New_Horiz_Column name attribute. For example, Month. Note that
this name populates the header for the new_horiz_column in the top
section of the column grid.
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2. In the top section of the column grid, replace the new value column header
with a name for the values column. For example, Revenue.

Do not enter values for the new_horiz-column column.
3. In the bottom section of the column grid, choose a range of columns to
rotate. For example, Rev01 through Rev03.
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4. Save the tab.
5. Right-click the Rotate object and click Test Object.
In the results you see only the columns within the range rotate. All other
columns do not rotate.

NOTE: The Start and End attributes are inclusive. The Previous and Next
attributes are not inclusive.

VI Sort Process Object
The Visual Integrator (VI) Sort process object changes the order in which the
data flow appears in subsequent objects.
The Sort object uses temporary files if there is not enough memory to perform
the sort in memory. All input rows are preserved without collapsing or
combining data. Use a Squash process object after the sort if you wish to
combine data. For more information, see VI Squash Process Object on page 96.
Object Attributes
You set attributes for the Sort process object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The Sort column grid displays the input columns and allows you to define the
sort order.

Example
This example sorts an input file with people's names and ages.
With the following input data:
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1. Set the Sort Order to 1 for the Person column and 2 for the Age column.

2. Save the tab.
3. Right-click the Sort object, and click Test Object.
The Results displays the sorted columns.
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NOTE: The data is sorted based on the primary sort, the Person column.
Rows with the same name are secondarily sorted by Age column.

VI Squash Process Object
The Visual Integrator (VI) Squash process object combines rows that are
identical for a set of dimension columns.
Optionally, the Squash process object summarizes numeric columns by
calculating the total, minimum, maximum, average, or standard deviation. It is
equivalent to the Builder squash attribute or an SQL GROUP BY statement.
Object Attributes
You set attributes for the Squash process object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
The Squash column grid displays the input columns and allows you to set squash
attributes for each.
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VI Output Objects Overview
You use Visual Integrator (VI) output objects to store data flow output. The
output object can define the data columns. If no columns are specified, all
possible data columns from the data flow are saved.
The following table describes each output object.
Visual Integrator Output Objects
Icon

Output
Object

Description

Builder

Creates a DI Model.

cBase

Creates a DI cBase.

Executes commands against the rows in the data
Execrows

flow, substituting parameters based on the data
flow columns.

Fileout

Iterate

Pipe
(UNIX only)

Setparm
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Saves the output data flow to a file.

Calls and iterates other VI tasks or task lists, varying
parameters based on input flow columns.

Feeds the output data flow into a UNIX pipe.

Sets parameters for later tasks in the VI script.
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Output
Object

Split

SQL

Tunnel

Description

Divides the data flow into separate output files
based on a data column.
Writes the output data flow to an existing
ODBC database.
Writes the output data flow to a file that any
DiveLine client can view.

VI Fileout Output Object
The Visual Integrator (VI) Fileout output object saves data to a file.
In addition to a data file, the Fileout object can also generate a dictionary file.
Either the data or dictionary file can be used as input to another VI script or as
input to Visual Builder.
Object Attributes
You set attributes for the Fileout output object in the attributes pane.

NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
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Column Grid
You set attributes for how the input columns appear in the output flow with the
column grid.

VI Split Output Object
The Visual Integrator (VI) Split output object splits data into a set of files
determined by the contents of the data. A data column in the input flow directs
the output. For each unique value of the data column, an output file is created
containing the corresponding data.
The Split object divides a data flow into separate output files for different sets of
data. For example, you can divide sales information into separate sales team files.
The Split object can also write out a dictionary suitable for input into Visual
Builder or back into VI. In addition, the Split object can write out a report file that
lists the created files and the number or records written to each file. There is no
limit to the number of files that the Split object can create; however, on Windows
platform the open file limit is 2040.
Object Attributes
You set attributes for the Split output object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
In the column grid, you set the Filename that indicates what the Split object uses
to produce output files. You also can set which columns are kept in these output
files.

VI cBase Output Object
The Visual Integrator (VI) cBase output object creates a DI cBase from the data
flow.
Object Attributes
You set attributes for the cBase output object in the attributes pane.
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NOTE: See Workbench Help for detailed descriptions of all the available
attributes.
Column Grid
You set attributes for the output cBase in the Model Structure column grid.

For each input column you can indicate the following column properties.
Column Properties Dialog Box
The Column Properties dialog box allows you to set detailed properties for
dimension, summary, and info field columns prior to building the model.
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Tree Grid
Use the Tree Grid to manipulate the output that displays in the ProDiver console.

Dimensional Insight

103

Additional Data Transformation

Workbench

The tree builds as you make selections in the Model Structure section, and the
dimension order in the tree is what appears in the ProDiver console.
In the Tree view you can:
l

l
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Double-click an item to open that column's Column Properties dialog
box.
Use the context menu commands to reorder items or change properties of

Dimensional Insight

Workbench

Additional Data Transformation

the tree grid.

NOTE: If the cBase output object was created by converting a Builder output
object and that Builder output object had the aliases or squash attributes set,
additional objects (Alias or Squash) are placed before the cBase output object.

Creating cBases with Visual Integrator Scripts
Creating a cBase with Visual Integrator is an easy process, but it hides some of
the complexities of the cBase creation process. To create a cBase with finer
control, use the Spectre Build script method.
To create a cBase using Visual Integrator:
1. Right-click a data file in the Workbench Explorer and choose Generate
Integrator Script.
The Save File dialog box opens.
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2. In the Save File dialog box, choose a location to store the file (defaults to
/programs, recommended), make changes to the default file name if
desired, and click Save.
A simple Visual Integrator tab opens with a Filein object.

NOTE: An asterisk appears in the tab indicating the file needs to be saved.
Click File > Save. Continue to save the file as you make changes.
3. Select the Filein object and note that it is using the data file as the input
under the Filename(s) or Starname(s) section [1].
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4. Make adjustments to the input fields on the right [2], setting which fields to
keep or remove, and setting any aliases. The keep order is set by the order
in which you select the fields.
5. Right-click the Filein object and choose New Object after this > Output
> cBase.
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Note that the cBase object connects to the Filein object.
6. Select the cBase object.
7. Add an output file name and location (/cbases recommended) in the
Output field [1] under the Misc section of the cBase object properties and
make selections in the Model Structure panel [2] on the right (see notes
below for more details).
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8. Save the tab.
9. Choose Run > Run Script or click the Run button (green circle with white
arrow) from the toolbar.
NOTE: If there are unsaved changes in the script, the Script has unsaved
changes dialog box opens with choices on how to proceed.
10. The Logs tab displays.
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NOTE: You may get warnings in the Log Viewer that mainly pertain to
values that have "suspiciously similar values" that you can ignore for the
moment. Spectre is letting you know that in your data, there are two things
that are probably supposed to be the same thing. It also lets you know
where you have leading zeros. You can later return to check these warnings
and make adjustments in your data file or build configuration as needed.
11. If the run is successful, the cBase opens in ProDiver and you can see the
results. This is a setting in Workbench Preferences.
NOTES:
l
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When the cBase object is selected, the Model Structure tab looks similar to
what you see with classic Models.
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You can make adjustments in the Properties of each column in the Visual
Integrator script (cBase object), such as changing summary fields into
strings so that they become dimensions.
Click the Props icon to access the Column Properties dialog box where you
can set additional properties.

If you require more detailed control, use the Spectre Build script method,
where you can iterate (with more control) between the Build script and
viewing the cBase in ProDiver to achieve a desired result.
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There are six possible properties panels in the Visual Integrator main window
(click the name label to change the panel display):
l

l

cBase-1-CBS (cbase)—Returns to the currently selected object properties
panel (cBase object in this example)
Parameters—Displays the Parameters pane to add or edit parameters for
this script

l

Results—Displays the results of the most recent run

l

Logs—Displays the logs (opens when you run the Visual Integrator script)

l

l

Columns—Displays a grid showing the origin of each column for each
task
Input/Output Files—Displays a grid showing the input and output files
used in the script

NOTE: After a cBase is built, feeding it into another Integrator script does not
preserve the column types, since Integrator treats all data as strings.
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Workflow and Scheduling
In this section, we will discuss:
What is Production?
Using the Task Flow Panel
Process Nodes
Control Nodes
Creating a Production Script
Parameters in Production
Parameter Process Node
Parameters in Visual Integrator
Creating Parameters in Visual Integrator
Inserting Visual Integrator Parameter Objects
Using Parameters in a Loop Node
Running Production Scripts
Workshop

What is Production?
A Diver Solution or Diver Platform implementation involves regularly scheduled
extraction, transformation, and load (ETL) tasks. Business rules are applied and
validated; cBases or models are created. These tasks can be quite complex and a
challenge to design, build, monitor, and maintain. Production helps back-end
developers frame their development efforts. It is a visual tool that allows for an
overview of a process, while facilitating construction, testing, and real-time
monitoring of the scripts. One or many Production scripts may be required
depending on the complexity of the data and desired outcome.
Production scripts are constructed using Process nodes that describe a specific
task and Control nodes that effect the process flow.
Data and control pass from one node to another as it travels from the Start
Control Node to the End Control Node in a script. As data travels from node
to node, each node performs its specified functions before passing control to the
next node in the script.
The direction of the flow is managed by Control nodes, while the data
processing is handled by the Process nodes. The direction of the flow is also
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determined by how a node is configured. A node can be configured to pass the
flow to one node if it succeeds and to a different node if it fails.
Once a script is created, it can be scheduled to run automatically at specified
intervals. Email notifications can be sent out when a script fails and/or succeeds.

Using the Task Flow Panel
The Task Flow panel is a canvas where nodes are placed and connected to create
a process flow to manipulate the data.
A new Production script opens with the required Start node placed in the Task
Flow panel.

1. Task Flow Panel—Place and connect nodes to create the flow of nodes to
perform specific data manipulation tasks.
NOTE: A red line at the top of a node indicates that one or more required
attributes are missing.
2. Required Settings—Red circle with an exclamation point indicates that a
required attribute is missing. Hover the mouse for a brief description.
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3. Information—Blue square with "i" indicates information is available for
the selected node. Hover the mouse for a brief description.
4. Node Tool Palette—Nodes to place on the Task Flow panel. Process and
Control nodes are shown in the screen capture above. If any Production
Extensions are installed, another section displays after the Control nodes.

Adding Nodes
There are several ways to place and connect nodes on the Task Flow panel:
l

l

l

l

l

l

Right-click an existing node and use the context menu to choose the next
node (right-click and choose New Object after this > Process/Control
> Node Name). This connects the new node to the existing node.
Single click a node in the Tool Palette. This connects the new node to the
currently selected node in the Task Flow. If no node is selected in the Task
Flow, a single click on a node in the Tool Palette places the node on the
Task Flow without connections.
Use a drag-and-drop operation from the Tool Palette to the Task Flow
panel. Dropped onto an existing node, this connects the two nodes;
otherwise, the new node is placed on the Task Flow without connections.
Use a drag-and-drop operation on an Integrator script from the Explorer
pane. This creates a new Integ node. Dropped onto an existing node, this
connects the two nodes; otherwise, the new node is placed on the Task
Flow without connections.
Use a drag-and-drop operation on a Build script from the Explorer pane.
This creates a new Build cBase node. Dropped onto an existing node, this
connects the two nodes; otherwise, the new node is placed on the Task
Flow without connections.
Use the Add Node toolbar button (green plus sign). This opens the Create
Node dialog box. Supply the following:
o Name—Enter a name for the node (if left blank, auto-populates with
the name chosen in Type)
o

Type—Choose a node from the Type drop-down list (brief
description displays in the information box)

o

Preceding Node—Choose the node to connect the new node to; use
the Node drop-down list (defaults to the currently selected node, if
one is selected) and choose the connection type (Connect upon:
Success, Failure, or Unattached)
Depending on the Connect upon type, the new node is placed and
attached to the previous and next nodes (if existing).
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NOTE: As you add nodes, you are presented with the opportunity to provide a
name. Production does provide a default name based on the node type
appended with a number, for example, Integ-1 that would then increment to
Integ-2 if another Integ node gets placed using defaults. It is best practice to
provide a meaningful name as you create nodes. You can always rename a node
by right-clicking it and choosing Rename.

Connecting Nodes
Each node has various types of connection points that become visible when you
hover over them.
All Process nodes (square shaped) and some Control nodes (circle shaped, such
as Wait and Loop) have three common connection points:
l

Input (not labeled)—Connects with the previous node (left side)

l

Success—Connects to the next node upon success (right side)

l

Failure—Connects to the next node upon failure (bottom)

Control nodes have additional connection points specific to the node type:
l

Conditional—Allows multiple next connections based on conditions

l

Loop—Requires setting the Loop Start and Loop Return connections

l

Fork—Allows multiple next connections to run simultaneous branches

l

Wait—Allows multiple inputs based on the number of simultaneous
branches set in the corresponding Fork node

NOTE: The Start and End nodes allow only one connection point.
Most methods described above result in automatic connections between nodes.
To manually work with connection lines, keep the following in mind:
l
l

l

118

To remove a connection line, select it and press Delete.
To connect two nodes, click the Success or Failure connection point of one
node and drag it to the Input connection of the next.
NOTE: Failure node connections use a dashed line.
Some Control nodes allow multiple connections and you can draw as many
lines to (or from) them as required.
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Process Nodes
Process nodes perform actions, from running an Integrator script, to copying
files, or building a cBase or model. Each type of process node performs a specific
type of function.
Icon

Process
Node
Build

Runs the Spectre Build application to build

cBase

a cBase.

Build

Runs the Builder application to build one

Model

or more models.

CacheDT

Copy

Delete

DIAL

Dive

Execute

Dimensional Insight

Description

Improves sync time for DiveTab
applications.
Copies or moves files from one location to
another location.

Deletes files and directories from the
specified location.

Executes one or more DIAL scripts.

Runs a Dive script that creates a query into
a cBase.

Executes one or more command line
commands.
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Icon

Process
Node

FTP

Integ

Measures

Workbench

Description

Pulls data from or pushes data to a server
through the File Transfer Protocol.

Runs one or more Integrator scripts.

Creates cPlans or cBases per data set as
described in a measures script.

Mkdir

Creates one or more subdirectories.

Parameter

Defines and sets parameters.

Generates DivePort pages in PDF or PNG
PrintDP

formats, with the option to save locally or
email the file.

Production Runs an entire Production script.

Spectre
Cache

Refreshes cached dives on the server.

Refresh
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Process

Icon

Node

Description

Pulls data from or pushes data to a server

Ssh

via Secure Shell protocol (SSH).
Creates a trigger file that can be picked up

Trigger

or interpreted by other scripts or
production processes.
Decompresses files from various

Unzip

compressed formats.
Compresses files into various compressed

Zip

file formats.

All process nodes have a concept of success or failure, depending on what the
node does. Nodes control where process flow will continue, based on that
success or failure.

Control Nodes
Control nodes allow you to manage the flow of your processing from node to
node.
Icon

N/A

Control
Node
Start

Conditional

Dimensional Insight

Description
Defines global settings. This is the built-in initial
node.
Handles the flow of a branch based on the values
for various conditions.
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Icon

Control
Node

Loop

Fork

Wait

End

Workbench

Description

Allows the process flow to proceed through a set
of one or more nodes multiple times.
Branches the task flow into multiple simultaneous
branches.
Specifies a Fork node with branches that must
complete before the flow can proceed.
Completes the flow processing on a branch based
on the values for various conditions.

Creating a Production Script
This topic describes the creation of a simple sample Production script that
creates a cBase, but first deletes the previous version. This is an example of a job
that may be scheduled to run nightly.
To create a Production script:
1. Choose File > New > Production Script.
The New Production Script browse dialog box displays.
2. Navigate to where you want to save the script, enter a file name, and click
Finish.
NOTE: You can alternatively right-click a folder and choose New >
Production Script and rename it in Workbench Explorer to locate the new
script within that folder.
A Start control node appears automatically where you can set some scriptwide settings such as the default email for notifications and the working
directory.
3. Right-click the Start node and choose New Object after this > Process >
Delete to set a Delete node for the second node.
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4. Set the file to be deleted in the Files section of the Delete node attriutes
pane.

5. Right-click the Delete node and choose New Object after this >
Process > Build cBase.
6. Set the Build file to use for this build in the Build Scripts section of the
Build cBase attributes pane.
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7. Finish the script by adding the optional End control node (right-click the
Build cBase node and choose New Object after this > Control > End).
8. Run the script by clicking the green circle icon with the white arrow.

Parameters in Production
Parameters allow flexibility in replacing attribute values within Production
scripts. Parameters are also used under the covers for communication between
the server and clients, for example DiveLine and Production, DiveLine and
DivePort, Production and DivePort.
You can define parameters so they are available at the following levels:
l

l

l

l

Entire script—Created in the Overview pane of the script. These
parameters are available to all nodes that accept parameters in all
branches.
Script Configurations—Created in the Overview pane of the script using
different configurations. These parameters are available as run-time
configurations parameters and can be set both manually as you run and
test a script as well as on scheduled jobs.
Node—Created in the attributes pane of any nodes that accept
parameters. These parameters are only available for the node where they
are created.
Branch—Created using the Parameter process node. These parameters are
available from this node on in the branch in which they appear, and in any
child branches.

See the Workbench Help for more information on Production parameters.

Parameter Process Node
A Parameter node is a Production process node that provides a mechanism to
define parameters whose values can be used by subsequent nodes that support
the use of parameters. These values can be supplied by text files.
When using a file to hold parameters, the file can be defined as single (default) or
multiple.
Single Parameter File Type Example
In this example, if the "Sales" configuration is selected, the "Office" parameter is
set to "New York" and the "Manager" parameter is set to "John."
Configuration
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Office

Manager
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Sales

New York

John

Marketing

Chicago

Mike

Engineering

Boston

Steve

Tech Support

Los Angeles

Jane

Multiple Parameter File Type Example
If the "New York" configuration is selected, the "CEO" parameter will be set to
"John" and the "CAO" parameter will be set to "Karen."
If the "Boston" configuration is selected, the "CTO" will be set to "Steve."
Configuration

Parameter_Name

Parameter_Value

New York

CEO

John

New York

CAO

Karen

Boston

CTO

Steve

Green Bay

Los Angeles

Jane

Parameters can be used by Production Control nodes and Process nodes. Often
parameters are use to call a Visual Integrator script, which first requires the
Visual Integrator script to have declared parameters.

Parameters in Visual Integrator
Parameters in Visual Integrator allow you to create user-defined variable
substitutions. These parameters become available for other scripts in the project
and are often used in Production scripts with Loop nodes that run multiple Visual
Integrator scripts based on parameter values.

Creating Parameters in Visual Integrator
To create parameters in Visual Integrator:
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1. Click the Parameters link at the bottom of the Visual Integrator tab.

2. Enter a name and at least a default value in the parameter grid that opens
in the Object Editor. Here a parameter named state has a default value of
nj.

Inserting Visual Integrator Parameter Objects
To insert a parameter in Visual Integrator:
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1. Right-click a field that accepts parameters (here we have selected a part of
the source filename) and choose Insert Parameter > <parameter_
name>.

2. When the script runs it will substitute the parameter value.
The parameters set in the Visual Integrator script can now be accessed by a
Production script, typically within a Loop node.

Using Parameters in a Loop Node
To illustrate the use of parameters, this topic describes a simple zip code
conversion that uses a VI parameter who's values are iterated with a Production
Loop node.
Process overview:
l
l

l

The three input files have the zip codes for NJ, NY, and PA.
A VI script is created with a parameter called $(state) that is used in the
input and output file names. The VI script concatenates the city, state, and
zip codes into a new calculated column included in the output files (citystate-zip).
A Production script is created with a Loop node that runs through three
iterations of the VI script—one for each state input file by using the
parameter values.
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First, you create a VI script that sets a parameter. In this example, we use a
parameter named state.
1. Create a VI script with three objects: Filein, Calc, and Fileout.

Given input text files with three columns—City, State, and ZIP) named nj_
zip_codes.txt.

The state abbreviation is different in each file name, so this is a candidate
for parameter usage.
2. Click the Parameters link at the bottom and enter state for the parameter
name and nj for the default value.
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Now that the parameter exists, you can use it in the VI script.
3. Select the Filein object and use the browse button for the Filename(s) or
Starname(s) and navigate to where the three zip code texts file are.
4. Highlight the two-letter state abbreviation and right-click > Insert
Parameter > state.

The parameter replaces the abbreviation in the form of $(parameter_
name), where the dollar sign indicates what follows is a parameter.
5. Insert the parameter in the Filename for the Fileout object to ensure the
output files are saved with the two-letter state abbreviation.
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6. Enter the following syntax in the Calc object to calculate the City-State-Zip
column in the output.
concat(City, ", ", State, " ", ZIP)
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7. Save the tab.
Then, you create a Production script with a Loop node with the VI script within
the loop that uses a parameter to iterate through the VI script until all $(state)_
zip_codes.txt files process.
1. Create a Production script with four objects: Start, Loop, Integrator, and
End.
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2. With the Integrator node selected, navigate to the VI script in the
Integrator Scripts panel and enter a parameter named state with the
value $(state) in the Parameters panel.
NOTE: It is a best practice to name the Production parameter the same as
the VI parameter.
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3. With the Loop node selected, enter the three state abbreviation values in
the Parameters panel at the bottom.
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4. Save the tab.
When you run this Production script, it iterates the linked VI script for the three
parameter values entered and you find three output files, each having the CityState-Zip calculated column.

Running Production Scripts
Production scripts help automate regular data processing tasks and can be run
manually or on scheduled intervals using various run configurations and
parameters.

Manually Running a Script
Production scripts can be run on schedules or manually. This topic describes how
to run scripts manually.
You can manually run closed or open Production scripts as described here.
Running Closed Scripts from Workbench Explorer
To manually run a closed Production script from Workbench Explorer:
1. Right-click the Production script in Workbench Explorer.

2. Click Run or Advanced Run. The latter is useful for complex scripts that
have parameters you want to set as you run the script.
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NOTE: Running a Production script from Workbench Explorer runs the
script with the default configuration. You need to open the script to run
with a different configuration.
Running Open Scripts
To manually run an open Production script:
1. Open the script.
2. Choose the appropriate configuration from the Configuration drop-down
list (top right).
NOTE: You can change parameter values in the configuration if you need
to test various values. The parameter table is located at the bottom right
under the Current Configuration section of the Overview pane.
3. Click the Run button (green circle with white arrow) on the toolbar.
4. When you choose to run the script, the Production tab switches to the
Show Results mode and each node passes through color changes to
indicate pass, warning, or fail state.

Scheduling Production Scripts
After you create a Production script, you can schedule a job to have it run one or
more times with the Production Job Schedule dialog box.
There are two places in the Workbench interface where you can manage
Production job schedules:
l

l

Overview pane (Production tab)—Allows you to set job schedules for the
currently open script. Requires the script to be open.
Start Page—Provides a consolidated view of all schedules set up on the
DiveLine connection.

Creating a Production Job Schedule from the Overview Pane
Production jobs can be set to run once or at regular intervals.
To set up a Production job from the script Overview pane:
1. Open the Production script.
2. In the Overview pane, click Add in the Schedules section.
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TIP: If the Overview pane is not visible, click anywhere on the white space
in the Task Flow panel and it displays.
The Production Job Schedule dialog box displays.

Dimensional Insight

137

Workflow and Scheduling

Workbench

3. In the Production Job Schedule dialog box, provide the following:
o

A meaningful name (defaults to the script's name prefixed with the Run
Configuration name). For example, Mainsales.prd, MAIN_DI_IR_
MAIN.prd

o

Inspect the Connection and Production Script display-only fields to
ensure you are working with the correct server and script.

o

Choose the Run Configuration from the drop-down list (if any)—
defaults to <default>. You define run configurations in the Manage
Configurations section of the Overview pane.

o

Choose the Schedule type from the drop-down list and provide
additional details (details change depending on schedule type).

4. Click OK.
The job is scheduled and appears in the list of schedules both here in the in
the script Overview pane and on the Start Page.
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Creating a Production Job Schedule from the Start Page
To set up a Production job from the Start Page:
1. Click Add (green plus sign) on the row for the DiveLine where the
Production script is stored.

The Select File dialog box displays.

2. Navigate to the Production script and click Select. Use the Select Project
to change projects as required.
The Production Job Schedule dialog box displays.
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3. In the Production Job Schedule dialog box, provide the following:
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o

A meaningful name (defaults to the script's name prefixed with the Run
Configuration name). For example, Mainsales.prd, MAIN_DI_IR_
MAIN.prd.

o

Inspect the Connection and Production Script display-only fields to
ensure you are working with the correct server connection and script.

o

Choose the Run Configuration from the drop-down list (if any)—
defaults to <default>. You define run configurations in the Manage
Configurations section of the Overview pane.

o

Choose the Schedule type from the drop-down list (each type is
described in the table that follows) and provide additional details (details
change depending on schedule type).
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4. Click OK.
The job is scheduled and appears on the Start Page list of schedules and
in the in the script Overview pane.
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Users and Groups
In this section, we will discuss:
Managing Users
User Edit Tabs
Managing Groups
Managing Project Access
Assigning Properties to Users and Groups
Workshop

Managing Users
Users are managed through the Server Settings > Users tab.
To manage users on a DiveLine connection:
1. Open the DiveLine connection. See Opening and Closing Connections on
page 23.
2. Choose Tools > Server Settings.
3. In the Server Settings tab, click the Users tab.
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The Users tab displays a list of the current users on this DiveLine connection. You
can manually resize most columns for readability. From this tab, you can review
the following user information:
l
l

l

Group associations.
Project access. For more information, see Managing Project Access on
page 161.
Client applications that the user is licensed to use. See the Workbench Help
for more information.

Filtering Users
You can filter and sort the list of users.
The search box searches for text in four columns of the users list: user, full name,
groups, and projects.
To filter the user list:
1. Enter text in the Search box.
The displayed list is filtered based on the characters entered.
2. Double-click the user to edit.
Sorting Users by Type
The icon to the left of the user column describes the user type.

l

Administrator

General User

Disabled

DI Staff Passport
Click the column header to sort users by type.
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The command icons (top right of user list) allow you to add, edit, copy, and delete
users.

Adding a User
To add a user:
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1. Click Add User.
The < New User > tab opens.

2. Enter settings for the user in the following tabs. For detailed information
about each tab, see User Edit Tabs on page 148.
l

General

l

Security/Licensing

l

Projects

l

Properties

l

About

3. Click OK.
The user is created and now appears in the users list.
4. Save the tab.
After the user is created, you can always return to edit the user.
Editing a User
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To edit the settings for a user:
1. Select a user in the user list on the Users tab.
2. Click Edit User. Alternatively, you can double-click the user.
The user's tab opens.

3. Edit the user's settings on the following tabs. For detailed information
about each tab, see User Edit Tabs on the next page.
l

General

l

Security/Licensing

l

Projects

l

Properties

l

About

4. Save the tab.
Copying a User
You can copy a user to create a new user with the same settings, which you then
can adjust as needed.
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To copy a user:
1. Select a user in the user list on the Users tab.
2. Click Copy User.
The Copy User dialog box opens.
3. Provide a unique name (required), password (required for
OWN authentication) and other Profile details.
Make adjustments on the other tabs as required. For detailed information
about each tab, see User Edit Tabs below.
4. Click OK.
The user is created and appears in the users list.
5. Save the tab.
Deleting a User
To delete a user:
1. Select the user in the user list on the Users tab.
2. Click Delete User.
3. Click Yes in the Delete User dialog box.
The user is deleted.
4. Save the tab.
NOTE: For bulk updates, you can use the command line dicfg tool. See the
Workbench Help for more information.

User Edit Tabs
When you add a new user or edit an existing user, you work with detailed
settings such as general, security and licensing, projects, and properties settings
on multiple tabs. This topic describes each of the settings on the user tabs.
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General
The General user tab is used for managing the user's profile, DiveLine settings,
and group associations.
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Profile
Enter the following details for this user:
l

l

The Username is not case sensitive. Avoid using special characters.

l

Full Name (Optional)—Specify the user's full name.

l

l

l
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Username (Required for all authentication types)—Specify the username
for this user. For Web Server authentication, the username must match the
name used by the web server. For Microsoft Internet Information Server
(IIS), the domain must be part of the name (for example,
<domain>\jsmith).

Short Name (Optional)—Specify a short name for the user. This setting is
useful for personalizing pages in DivePort.
Description (Optional)—Specify a description. This setting is useful
documentation for maintenance tasks.
Email (Optional but recommended)—Specify the user's email address to
support Controller, Production, DivePort, and Measure Factory messaging.
The Email address is required for DivePort password reset to function with
OWN authentication and is also required for Measure Factory collaboration
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functionality. The Email address can be used by DI-Broadcast and
referenced by DivePort and Controller.
NOTE: Each of these settings, except the Description, are available as variables
in DivePort.
DiveLine
The user DiveLine settings specify the user's home directory, the DiveBook that
opens when the user logs on to ProDiver, and the application template file, which
defines the appearance, preferences, and functionality of the ProDiver client.
Set the following fields if using these features:
l

Home Directory (Optional)—Enter the path to the user's home directory,
which is the directory where DI recommends users store any work saved in
ProDiver and NetDiver. See the Workbench Help for more information.
NOTE: The following points apply only when the DiveLine server has the
home project feature enabled. For more information about the home
project feature, .
o

If you are creating a new user, leave the Home Directory field set to
the default pattern. By default, the DiveLine server sets the home
directory to the $(USER) variable, which uses the username as the
name for the user's home directory in the folder /di-users/. If
there is a domain name as part of the username, a subdirectory is
created for the domain.

o

If there are existing users, you need to set them up to use the home
project and home directories. For more information, see Retrofitting
Users for the Home Project on page 42.
When users first log in with ProDiver or NetDiver, the DiveLine server
creates the specified home directory in the home project and sets
access control appropriately to match the pattern set in the Settings
chevron section at the top of the Users tab. For more information,
see Setting the Home Directory Settings on page 38.

l

DiveBook (Optional)—Specify the DiveBook to use to organize end-user
files, such as DivePlans, cPlans, markers, and dive files. The DiveBook opens
each time the user logs onto ProDiver.
If the home project feature is enabled, leave the project set to
<HOME PROJECT>, and click the browse button to navigate to the
DiveBook file (dbk) in the <HOME PROJECT> folder.
If the home project feature is not enabled, select a project from the list, and
browse to a DiveBook file in the selected project.
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App Template (Optional)—Specify the application template file that
defines the appearance, preference settings, and available functionality for
the ProDiver client.
If the home project feature is enabled, leave the project set to
<HOME PROJECT>, and click the browse button to navigate to the
application template file (tpl) in the <HOME PROJECT> folder.
If the home project feature is not enabled, select a project from the list, and
browse to the application template file in the selected project.

Group
In the Group section, select the check box for each group where this user should
be a member.
Security/Licensing
The Security/Licensing tab is used to adjust DiveLine security settings and
select client applications for the user.
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Administrator and Owners
Set the following options to define administrator user access:
l

l

Administrator User (Optional)—Select the check box to make this user
an administrator on this DiveLine server.
Owned By (Optional, for non-administrator users)—Select the check box,
and specify an owner to administer this user. The Owned By option is
available only if the option Non-Administrators can be set to administer
other users has been set on the General tab of Server Settings. The
option is unavailable if Administrator User is selected.

NOTE: All DiveLine administrators automatically become DivePort
administrators. To change this configuration, adjust the user's access level in
DivePort's Users and Groups dialog to something other than Use Default.
Authentication
In the Authentication section, you can set the following:
l

Override User Authentication (Optional)—Allows you to override the
default DiveLine authentication setting set on the General tab of Server
Settings. See the Workbench Help for more information.
NOTE: You can set a local password here only when using the OWN
authentication type.

l

l
l

l

Password (Required for OWN only)—Specify and verify the user's
password.
Password never expires (Optional)—User's password never expires.
User cannot change password (Optional)—User is not allowed to
change the password.
User must change password after next login (Optional)—User is
prompted to change the password when logging on.

Access
In the Access section, you can disable the user's account or NetDiver access.
Client Licensing
In the Clients list, select the check box for the DI applications that this user can
access. Developer selects all of the clients, but only uses a developer license. The
Developer category also affects what is available on the Projects tab.

Dimensional Insight

153

Users and Groups

Workbench

TIP: Do not confuse DivePort service users with regular DiveLine users. The
service user specified in the context xml file during installation (often _Admin),
does not need to have a license assigned to it.
NOTE: Help Desk licenses require that the user is a DiveLine administrator.
Projects
The Projects tab is used to select which projects the user can access and, for
non-administrators, to set the user's access level:

l

l

Project—Lists the projects on this DiveLine server. A green check mark to
the left of the project name indicates that the user has access.
Access Level—Lists access levels (None, User, Group, Developer) and
allows you to select an access level for this user. See Managing Project
Access on page 161.
NOTE: For administrator users, the access level is set to Administrator
and cannot be changed.

l

Groups—Lists any groups associated with each project.

Properties
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The Properties tab is used to associate properties and values with the user. The
properties are used to set access control rules that control user's data access. For
more information about properties, see the Workbench Help, Assigning
Properties to Users and Groups on page 166, and Access Control Overview on
page 173.

About
The About tab is a display-only tab that shows audit information about the user.
This information appears as Unknown until you save the user. You can view the
information by editing the user.
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Managing Groups
A group is a collection of users that share similar access requirements. Using
groups simplifies managing access to projects and data. If a user belongs to
groups that have differing access to a resource, the user's access is determined
by a union of each group's access settings.
Groups are managed through the Server Settings > Groups tab.
Prerequisite: To manage groups on a DiveLine connection, you must open a
connection to the DiveLine server. For information about opening a connection,
see Opening and Closing Connections on page 23.
To manage groups:
1. Open the DiveLine connection.
2. Choose Tools > Server Settings.
3. In the Server Settings tab, click the Groups tab.
A listing of the current groups on this DiveLine connection displays.
The command buttons to add, edit, copy, and delete groups are at the upper right
of the group list above the column headings. If you have a large number of
groups, you can use the search box, to the left of the command buttons, to filter
the number of groups that display. The search looks for a text in three columns
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of the groups table (Group name, Description, and Owner) and limits the display
to groups that match the characters typed.

Filtering Groups
To filter the group list:
1. Enter text in the Search box.
The search filters the list based on the characters entered.
2. Use the command buttons to process the selected group.
Adding a Group
To add a group:
1. Click Add Group on the Groups tab.
The Add Group dialog box opens.
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2. Supply the following information:
l
l

l
l

l
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Enter a name for the group.
Click the Owned By check box, and replace the <Enter User/Group>
text with the name of a user or group. As you type, available names
are suggested.
Add a description in the Description box.
Select the check box next to each user in the Members list that you
want as a member of this group.
Click the Project and Properties tab:
o

Select the check box for each project that this group can access.

o

Assign properties and property values for this group.
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See also Assigning Properties to Users and Groups on page 166.
3. Click OK.
After the group is created, you can edit the group and adjust profile
information, change memberships, set project access, and assign
properties.
4. Save the tab.
Editing a Group
To edit a group:
1. Select the group in the Groups tab.
2. Click Edit Group. Alternatively, you can double-click the group.
The group tab opens.
3. Make edits as required in the General and Projects and Properties tabs.
l

General tab—Edit the group owner, description, and members.
Projects and Properties tab—Edit project access and assignment of
properties and values.

4. Save the tab.
Copying a Group
You can copy a group to create a new group with the same settings, which you
then can adjust as needed.
To copy a group:
1. From the Groups tab, select a group in the group list.
2. Click Copy Group.
The Copy Group dialog box opens.
3. Provide a unique name (required) and make adjustments to any other
Profile details, including selections in the Members list.
You can make adjustments on the Projects and Properties tab as
required.
4. Click OK.
The group is created.
5. Save the tab.
Deleting a Group
NOTE: Deleting a group removes any resource access group members had
through this group membership.
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To delete a group:
1. Select a group in the Groups tab.
2. Click Delete Group.
3. Click Yes in the Delete Group confirmation dialog box.
4. Save the tab.
For more information about project access and assigning properties and values
to groups, see Managing Project Access below and Assigning Properties to Users
and Groups on page 166.

Managing Project Access
You manage project access on the DiveLine connection level (Tools > Server
Settings) either through the Projects tab or the Groups and Users tabs.
NOTE: This topic describes settings in Workbench that grant or limit project
access. In addition, there are access control rules that you can set to grant or limit
access to specific areas in the project as well as to columns within the data. See
Access Control Overview on page 173.
There are several ways a user can have access to a project:
l

The user is an administrator for the server.

l

The user is a developer for the project.

l

l

The project has the Allow Access to all Users check box selected, or the
user has access to a special home project (if this feature is implemented).
The user belongs to a group that has access to the project.

Most users will have access to projects through a group association. The
following sections describe how to provide project access with each method.
Administrator Users
Select the Administrator User check box on the Security/Licensing tab for the
user.
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Each administrator user you add to a DiveLine connection will have access to all
projects on that DiveLine connection. Note that there is a green check mark next
to each project in the Projects tab for this user, and the Access Level is
Administrator for all projects.
Project Developers
You can grant selective administrator project access (on a per-project basis) to a
user to work on specific projects by assigning that user the Developer access
level.
NOTE: You must first set the Allow non-Administrator Project Developers
flag (in Sever Settings > General > User Management section) to enable use
of Projects Access Level settings. See the Workbench Help for more
information.
To set a user as a project developer on a project:
1. Double-click the user in the Users tab, and click the Projects tab.
2. For the specific project, select a level (None, User/Group, or Developer)
from the Access Level drop-down list.
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None—The user cannot open anything in the project.
User/Group—The user or group can read and write files within the
project per the normal access control rules (see Access Control
Overview on page 173). Most users fall in the User category as users
of cBases and Models.
Developer—The user has full access to everything in the project and
is not subject to the access control rules. Users in the Developer
category can create and run Integrator and Production scripts.
However, how much true administrative access this developer has
depends on the Allow non-Administrator Project Developers
setting (Tools > Server Settings > General > Security > User
Management). See the Workbench Help for more information.

3. Save the tab.
Setting Allow Access to all Users
To set Allow Access to all Users:
1. Open the DiveLine connection. See Opening and Closing Connections on
page 23.
2. Click Tools > Server Settings.
3. In the Server Settings tab, click the Projects tab.
4. Select the project from the project list, and click Access List, which is the
right-most command button. Alternatively, you can double-click the project
to open the access list.
5. Select the Allow Access to all Users check box. Note that there is a green
check mark next to each DiveLine user for this project as shown here.
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6. Save the tab.

Any future users added after selecting the Allow Access to all Users check box
will also have access to this project.
NOTE: When the home project feature is enabled, the Allow Access to all
Users check box is automatically set so that all users on the DiveLine have access
to the home project and their home directories.
Setting Project Access from the Groups Tab
To set project access from the Groups tab:
1. Click the Groups tab.
2. Select the group from the list, and click Edit Group. Alternatively, you can
double-click the group.
3. Click the Projects and Properties tab.

164

Dimensional Insight

Workbench

Users and Groups

There is a check mark in the Access column of each project that the group
can access.
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4. Select additional project check boxes to grant the group access to
additional projects.
5. Save the tab.
NOTE: You can make most of these project access settings through the Projects
tab. Setting a user as an administrative user is only possible on the user's
Security/Licensing tab.

Assigning Properties to Users and Groups
This topic describes how to assign properties to users and groups. These
properties are used to control who has access to various areas of the project's
data. See the Workbench Help for more information.
NOTE: These procedures are not necessary when you use an external property
file. In that case, the property values and assignments are included in the
property file. These are view-only on the user's Properties tabs or the group's
Project and Properties tabs.
Assigning Properties to Users
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To assign properties to a user:
1. Click the Users tab.
2. Select the user, and click Edit User. Alternatively, double-click the user.
3. Click the Properties tab.
Available properties are listed.

NOTE:
l

l

<None> in the Assigned Values column indicates that the property
has values, but no values are yet assigned.
Dimmed <NA> in the Assigned Values column indicates that these
properties have the values and user or group assignments in a
property file. See your DiveLine administrator.

4. Click <None> in the Assigned Values column for a property.
A list of possible values displays.
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5. Click the Assigned To User check box for each value that you want to
associate with this user.
NOTE: If appropriate for this user, you can click the <All Values> check
box, and all property values are associated with the user.
6. Click the OK check mark, or click anywhere in the Property Name column,
to close the values list.
The property values are now associated with the user and appear in the
Properties tab for that user.

7. Save the tab.
Assigning Properties to Groups
To assign properties to a group:
1. Click the Groups tab.
2. Select the group, and click Edit Group. Alternatively, double-click the
group.
3. Click the Projects and Properties tab.
Available properties are listed.
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4. Click <None> in the Assigned Values column for a property.
A list of possible values displays.
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5. Click the check box next to each value that you want to associate with this
group.
NOTE: You can check the <All Values> check box if appropriate for the
group.
6. Click the OK check mark, or click anywhere in the Property Name column,
to close the values list.
The property values are now associated with the group and appear in the
Properties tab for that group.

7. Save the tab.
See also:
l
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Security (Access Control)
In this section, we will discuss:
Access Control Overview
About Access Control
Access Control Interface
Access Control Process
Access Control Categories
Directory Overview Tab
Access Control Conditions
Properties: Separating Access Control Rules from Data Values
Access Control Effects
Workshop

Access Control Overview
There are several aspects to setting access control, that is configuring the
security, in Workbench projects. This topic gives a general work flow and links to
specific topics for steps.
At the basic level, you grant or restrict project access to users and groups.
At a more advanced level, you use Workbench properties when configuring
access control to grant or restrict access to specific files, folders, or columns and
rows within a cBase or classic Model, based on the property values assigned to
users and groups.
The general work flow for setting access control is:
1. Create users.
2. Create groups and assign users to them.
3. Create properties.
4. Set project access for users and groups.
5. Assign properties and specific values to users and groups.
6. Use these properties to configure access control for specific folders in the
Workbench Explorer. You can also use these property values in other
scripts.
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NOTE: DI recommends using properties as the main way to set access control
rules because properties allow you to separate the rules from the data values.

About Access Control
Access control consists of rules that you set to control the security of a
Workbench project. You can set these rules at the project level or the directory
(folder) level, and you can control who can access the parts of your data sets that
are contained in cBases or models. In addition, you can define audit rules to
capture and log which users have accessed particularly sensitive data.
By default, Workbench projects allow full access to administrative users and
completely restrict access to non-administrative users. That is, access control
rules default to the most restrictive for non-administrative users. You can grant
the non-administrative users permissions to access directories and portions of
your data sets with the access control rules.
These rules fall into the following categories:
l

File Access

l

cBase Access

l

Model Access

l

DiveTab Access

l

Audit Rules

Each rule is set either without or with a condition. Without a condition, the rule
applies to all users. With a condition, the rule applies to a specified group, user,
or property.
The condition types are:
l

All Users—Applies to all users (default)

l

Group—Applies to everyone within the named group

l

User—Applies to the specific user

l

Property—Applies to any user or group that has the specified property and
value(s) pair

Opening the Access Control Tab
1. Right-click the project or folder in Workbench Explorer, and click Edit
Access Control.
The Access for / tab opens. Note that the forward slash ("/") indicates that
this is the project root. A directory name appears when opening from a
folder, for example, Access for /cbases.
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2. Click the appropriate sub-tab to set the access control rules you need.

Inheritance:
Access control is either set on a project or directory, or it is not. This is true of all
access control categories. If access control is not defined for a directory, then
access control rules are inherited from the nearest ancestor that has any rules
defined. It is not possible to inherit access for only one category. For instance, it is
not possible to inherit file access control without also inheriting cBase access
control. If no ancestor has access control defined, then the default, restrictive
access is used.

Access Control Interface
Access control rules are set on the access tab, which you access when you rightclick a project or directory and select Edit Access Control. The access control
interface consists of several sub-tabs where you set the rules for each category.
Note that the following numbers refer to numbers in the sample screenshot:
l
l

Category name (1)—Displays the name of the selected sub-tab
Project path (2)—Displays the project path, as shown in the graphic as
us-sales path: / where the forward slash ("/") represents the root of the
project us-sales
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Filter drop-down list (3)—Displays a listing of users and groups that you
can use to filter the listings when you have numerous rules
Rules tables (4)—Displays one or more tables, based on the selected subtab where you set the individual rules
Sub-tabs (5)—Selects and displays the selected access control category

Access Control Process
Setting access control to ensure your files and data are secure has many parts.
The rule settings in the access tab is one of the final steps. To understand
prerequisite steps that you might need to prepare, review the Access Control
Overview on page 173, which discusses the overall process.
Work flow for setting access control rules:
l

At the project level, set file access to allow read and write (if
applicable) permissions for non-administrative users.
This allows non-administrative users to see the project files. It allows them
to see all of the project directories, so you will need to restrict these users
from any directories that you do not want them to see.

l
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Restrict non-administrative users from any directories that you do not
want them to see.
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This is achieved by clearing the Inherit from ancestor check mark on the
Directory Overview tab of the access tab for each folder that you do not
want these users to see.
Basically, you first grant full read and write permissions for file access to
the entire project, then restrict access to any directories that you do not
want the user to see.
l

Set the data-specific access rules to control what each user and group can
see within the data set.
For data sets (cBases and models), you first restrict columns and then allow
specific users or groups access, which is most often done through
property/values assignments. You can also set limit rules for rows. For
DiveTab access rules, you first restrict DiveTab areas (buttons) and then
allow specific users or groups access to them. When DiveTab applications
access cBases, the row and columns rules apply to the display of DiveTab
data pages.

NOTE:
l

l

Rules which include a conditional tag (if-property, if-group, if-user) are
considered conditional rules. See Access Control Conditions on page 181.
These conditional if tags are only visible as such in the script. In the
interface, they are presented as a choice in the Condition column of the
rules tables.

The All users choice sets that rule without a condition so that the rule
applies to all users. This is the default setting that places no if statement for
the rule in the underlying script.
l

When looking at the access file, before making access decisions, the
DiveLine server scans all of the conditional rules and tests each to see if it
applies to the current user attempting to access data. If the rule does not
apply to the user, the rule is removed from consideration—it would be as if
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the rule were not present at all.
l

Only the rules with satisfied conditions or without any condition at all are
processed to determine effective access.

Inheritance:
l

l

Each directory (folder) below the project level defaults to have the Inherit
from ancestor check mark selected and does not display any of the
category sub-tabs.

To make any changes to the access control rules for this directory, you
must first clear the Inherit from ancestor check mark, which then
displays all of the sub-tab categories.

Access Control Categories
Access control rules can be set for the following categories:
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File Access

l

cBase Access

l

Model Access

l

DiveTab Access

l

Audit Rules

Security (Access Control)

The access control interface has a separate sub-tab for each of the categories
where you set the rules.
This sample screen shows that you can view a summary of existing rules (1), set
access rules per category (2), work with the underlying script (3), and inspect the
status of any existing subdirectories (4). Numbers here refer to the numbers on
the sample screen. The tab label displays the path to where this access control
tab resides. In the example, it is at the project root that is represented by the
forward slash (/) with Access for /.

DI recommends that you set your access control rules at the root of the project,
where the tab name is Access for /, as in the example. All the other directories
and any subdirectories default to inherit access control rules from the ancestor,
which is most often the project root. You can set access control rules on
individual directories, by clearing the Inherit from ancestor check mark for the
directory's access control tab.
Each rule category can have multiple access control rule types. For example, for
the file access category, there are read and write rules, and for the cBase access
category, there are row-based and column-based rules.
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All access control rules have two parts:
l

l

Condition—Who does this rule apply to? See Access Control Conditions on
the facing page.
Effect—What does this rule do? See Access Control Effects on page 183.

The effect can be complex, since it is a combination of the rule type and the
parameters of the rule.
Effects vary depending on category and the rule types selected. For ease of
maintenance, consistency of usage is encouraged within a project.

Directory Overview Tab
The Directory Overview tab of an access tab provides a summary of any
existing access control rules.
The sample screenshot shows rules set for each category.

NOTE:
l

l
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You can expand a category to see more details. Full details are available
from the individual category tabs.
The Subdirectories section on the right shows the access control status
of each directory below the currently selected directory. The example
shows the project root selected. A directory will either inherit from the
ancestor (INHERIT FROM/) or have its own rules set (OWN ACCESS).
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You can right-click a directory and choose Edit Access Control to go
directly to the access tab for that directory.
l

You can click refresh for the Subdirectories section to ensure any added
directories and Status changes appear.

Access Control Conditions
Access control Condition and Condition Details describe to whom the rule
applies. These condition choices are the same for every rule category. The
following screenshot shows an example file access rule set.

NOTE: To set rules for multiple conditions, you add a new row to the rules table
for each condition.
The following table details the four different condition types.
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Condition Condition Details

Description

Group

Provides the list of groups

Rule applies to everyone in the

on the DiveLine

selected group

User

Provides the list of users on Rule applies to the selected user
the DiveLine

Property

All Users

Provides the list of

Rule applies to any user or group

properties (and values) on

that has a given property and value

the DiveLine

(s) pair

n/a

Rule applies to everyone

NOTE: Non-administrator project developers can edit a project's access control
settings. Because they are not full DiveLine administrators, the lists of users,
groups, and properties do not populate in the access control interface. The nonadministrator project developer must enter these values by hand.

Properties: Separating Access Control Rules from Data
Values
Although the access control rules allow you to explicitly include dimension
values by using the limit-dimension and limit-rows-by-values tags, DI
recommends that you do so only on a limited basis.
As a best practice, DI recommends that you separate the access control rules
from any data values. You can achieve this separation by using properties. By
separating the access control rules from the data values, you can set the rules
once based on the properties and not touch them again. Once the access rules
are set, security is addressed at the user and group level by property values
assignments. As users come and go, or change roles in the organization, you
adjust the property value assignments either for the specific user or for the
groups that the user is a member of. Not needing to modify access rules, but just
the assigned values, minimizes errors that could upset existing security settings
for users.
You define properties on the server and associate values on the Server Setting
> Properties tab. You define rules using those properties. When you create
users or groups, all properties are available. If you want a property to apply to a
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user or group, you set the assigned values as part of the profile on the Server
Settings > Users > <user> > Properties tab or Server Settings > Groups >
<group> > Projects and Properties tab. When users log in, access rules are
applied based on their assigned properties and values. That is, when the system
determines a particular user's property values assignments, it takes the union of
all the values contributed by assignments for the groups that this user is a
member of, and any explicit assignments for the particular user.
NOTE: It is always best to use role-based assignment when possible. If you tie
rules to a particular user, you create a maintenance headache as people come
and go. If all access is done using groups, it is simple to move users in and out of
groups as needed. This means that it is best to assign property values at the
group level whenever possible.
For example:
Suppose you have a cBase with Sales Region data. The Salespersons are allowed
to see all data for their region. You could define a property called Allowed
Regions on the server and have for values the individual regions. Then, create the
rule to limit access based on that property. For example, define a row-based
cBase rule for all users that limits the column Sales Region to values in the
Allowed Regions property.

The Salespersons are assigned to groups, and each group has the Allowed
Regions property set to the value of the region name; for example the group
North has the value North, and the group Boston has the value Boston.
Each Salesperson who opens the cBase sees data according to the assigned
values for the Allowed Regions property.
TIP: Property value assignments can be set from an external file. You could, for
example, have a nightly external process that creates a flat file used to update
property values and assignments. Once set, the rules do not change—just the
assignment of values to properties.

Access Control Effects
Each access rule category uses the same possible conditions and condition
details to define the to whom value that the rule applies. However, the available
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effects of each rule differs per category. Below are descriptions of the effect
settings available for each of the access categories.
File Access
Consists of two setting types: read permissions and write permissions. These
permissions allow you to set who can read and write to a project or directory.
Example

NOTE: Setting read and write permissions at the project level gives users access
to all directories in the project. Then, you need to remove read access to any
directories in the project that you do not want a user to see. This limits what
appears in the ProDiver Open dialog box.
cBase Access
Consists of two setting types: row-based rules and column-based rules.
In the row-based rules, you can set Limit Type. Possible settings are:
l

Allow All

l

Limit By Values

l

Limit By Property

l

Limit By Username Column

l

Limit By Filter

In the column-based rules, you first restrict columns and then set rules that allow
some users to see these restricted columns.
NOTE: You can use only one restrict-columns rule within a cbase-access rule
set, but the restricted columns can have multiple columns listed. Multiple allowcolumns rules are allowed so that you can allow access to restricted columns for
specific users, groups, or those with a certain property and value(s) applied.
Example
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Settings and Preferences
In this section, we will discuss:
Server Settings Overview
Project Settings
Setting Workbench Preferences

Server Settings Overview
Administrators can use the options in the Server Settings tab (Tools > Server
Settings) to inspect and edit settings of DiveLine, which is the server component
of the Diver Platform and Diver Solution software. The Server Settings give you
centralized control of your DI users, data, and processes. Diver clients, such as
Workbench, ProDiver, DivePort, and DiveTab, all connect and authenticate
through the DiveLine server. In the Server Settings, you can define the DiveLine
authentication type, administer users and groups, control access to project files,
view details about the DiveLine activity, and configure advanced settings.
The options in the Server Settings apply to the current DiveLine connection,
which is shown in the server Connections list.
NOTE: Changes made to these settings propagate to other users who have
Server Settings open. If there are conflicting changes upon saving, those users
are notified with a dialog box.
In Server Settings, you can inspect and edit various aspects of this DiveLine
through the following tabs:
l

General—Displays information about the DiveLine configuration. You can
administer authentication type, DiveTab connection (if the current
connection is a DiveTab connection), email notifications, and additional
options. This is the default tab.

l

Users—Displays a list of users. You can add, edit, and delete users.

l

Groups—Displays a list of groups. You can add, edit, and delete groups.

l

l

l

Projects—Displays a list of the projects. You can add, edit, and delete
projects and manage user access to those projects.
Properties—Displays a list of properties. You can create and edit
properties, which are used in access control.
Controller—Displays details about each active session. You can manage
the connected users.
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Advanced—Displays information about executable paths and Production
Extensions. You can modify the executable paths and install and uninstall
extensions.

Project Settings
The Project Settings tab (Tools > Project Settings) allows you to review and
edit various aspects of the project components through the following tabs:
l
l

Project Overview—Provides an overview of the project.
Project Contents—Provides a catalog of the file contents and a
representation of file dependencies within the project.

l

Aliases—Allows you to create and manage project and system aliases.

l

Mailing Lists—Allows you to create and manage mailing lists.

l

Version Control—Allows you to set up automatic version control backups
and set Visual Integrator audit logging.

Setting Workbench Preferences
The Preferences dialog box allows you to customize Workbench default
behaviors.
To set Workbench preferences:
1. Click Tools > Preferences.
The Preferences dialog box appears.

2. Select a category in the left pane.
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3. Make adjustments in the right pane.
4. Click OK.
Table 14-1 Workbench Preferences Dialog Box
Category
General

Behavior

Settings
l

Paths—Editable path to associated executable files.

l

Startup—Customize how Workbench starts up.

l

Content—Customize how the interface behaves with
content, such as turning off initial comments in scripts,
setting it to show when a scheduled script has any
warnings, and whether to keep or remove unlinked
schedules.
NOTE: Initial Comments guide the user through the
process of creating a new script file. If turned off, then files
will default to having just the top level tag. This feature is
useful for advanced users that no longer need hints.

l

l

l

Visual

l

Integrator
l

l

l

Dimensional Insight

Interaction—Customize notifications for failed jobs and
saving credentials. Failed jobs default to display an error
pop-up dialog box when foreground job fails.
Save—Customize how Workbench saves modified scripts,
and the behavior when running.
UI—Customize the initial state of the left panel of the
Startpage at start up, how the connection tree displays,
and the border size between Workbench interface parts
(defaults to 5 pixels).
Behavior for Runs—Set and turn on/off input/output
limits, run and save options.
Behavior for Tests—Set and turn on/off input/output
limits, test inclusions/exclusions, and Qual string options.
Functionality—Customize how Workbench handles
Visual Integrator scripts, including naming, paths, word
wrap, encoding, ODBC, and SQL connections.
Interface—Customize interface elements, including autosave time, backups, tooltip displays, sorts for functions and
data.
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Category

Settings

Production

l

DiveMaster

l

l

Spectre
Build

Workbench

l

Parameters—Set how Production works with existing
parameters.
Dialogs—Customize dialog box behaviors for aliases,
columns, and categories.
Functionality—Set file encoding defaults.
Run Diver after build—Set whether or not to have the
cBase open directly in ProDiver when a Spectre Build script
successfully completes (defaults to False).

Editor
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